summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-10-24 09:22:43 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2021-10-24 09:27:37 +0200
commit253386480c1683936043df8787b6527046a866b2 (patch)
treef90246db0855385894bdf74c43021ba47cef1227 /x11-plugins/wmppp
parentmedia-sound/mpg123: bump to 1.29.2, dropped 1.29.1 (diff)
downloadgentoo-253386480c1683936043df8787b6527046a866b2.tar.gz
gentoo-253386480c1683936043df8787b6527046a866b2.tar.bz2
gentoo-253386480c1683936043df8787b6527046a866b2.zip
x11-plugins/wmppp: bump to EAPI 8
Closes: https://bugs.gentoo.org/819156 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins/wmppp')
-rw-r--r--x11-plugins/wmppp/wmppp-1.3.2-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/wmppp/wmppp-1.3.2-r2.ebuild b/x11-plugins/wmppp/wmppp-1.3.2-r2.ebuild
new file mode 100644
index 000000000000..4c455b17c358
--- /dev/null
+++ b/x11-plugins/wmppp/wmppp-1.3.2-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit toolchain-funcs
+
+MY_P=${PN}.app-${PV}
+DESCRIPTION="PPP dial control and network load monitor with NeXTStep look"
+HOMEPAGE="http://www.dockapps.net/wmpppapp"
+SRC_URI="http://www.dockapps.net/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+
+# Specific to this tarball
+S=${WORKDIR}/dockapps-7ec9002
+
+DOCS=( BUGS CHANGES HINTS README TODO )
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ einstalldocs
+}