summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmwifi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmwifi')
-rw-r--r--x11-plugins/wmwifi/Manifest1
-rw-r--r--x11-plugins/wmwifi/metadata.xml5
-rw-r--r--x11-plugins/wmwifi/wmwifi-0.6.ebuild35
3 files changed, 41 insertions, 0 deletions
diff --git a/x11-plugins/wmwifi/Manifest b/x11-plugins/wmwifi/Manifest
new file mode 100644
index 000000000000..5ef848566e55
--- /dev/null
+++ b/x11-plugins/wmwifi/Manifest
@@ -0,0 +1 @@
+DIST wmwifi-0.6.tar.gz 150482 RMD160 053ab047fbe41a1af9386aefe2081ef9882acb5c SHA1 bea63b5e8f3dcfa68035d78b00578d15d294a0bd SHA256 b01f62f05aae476353e12cb48f9f914a40df7b00285fdd4349ca314b5a019f54
diff --git a/x11-plugins/wmwifi/metadata.xml b/x11-plugins/wmwifi/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmwifi/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmwifi/wmwifi-0.6.ebuild b/x11-plugins/wmwifi/wmwifi-0.6.ebuild
new file mode 100644
index 000000000000..fb6d5027ed07
--- /dev/null
+++ b/x11-plugins/wmwifi/wmwifi-0.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+IUSE=""
+HOMEPAGE="http://wmwifi.digitalssg.net"
+DESCRIPTION="wireless network interface monitor dockapp"
+SRC_URI="http://digitalssg.net/debian/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+src_compile()
+{
+ econf || die "Configuration failed"
+
+ # by default it does not honour our CFLAGS
+ emake CFLAGS="${CFLAGS}" CPPFLAGS="${CFLAGS}" || die "Compilation failed"
+}
+
+src_install()
+{
+ dobin src/wmwifi || die
+ doman wmwifi.1 || die
+ dodoc AUTHORS README || die
+}