summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-22 17:43:03 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-08-02 22:12:53 +0200
commit0196b7f60f4c131dda29d77cc70c7d84d887ed66 (patch)
treea693da76725ac7b9ed643d625d44f15f0e713bcf /x11-plugins
parentx11-plugins/wmlife: EAPI7, improve ebuild (diff)
downloadgentoo-0196b7f60f4c131dda29d77cc70c7d84d887ed66.tar.gz
gentoo-0196b7f60f4c131dda29d77cc70c7d84d887ed66.tar.bz2
gentoo-0196b7f60f4c131dda29d77cc70c7d84d887ed66.zip
x11-plugins/wmload: EAPI7, improve ebuild
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmload/files/wmload-0.9.6-solaris.patch4
-rw-r--r--x11-plugins/wmload/wmload-0.9.7-r1.ebuild33
2 files changed, 35 insertions, 2 deletions
diff --git a/x11-plugins/wmload/files/wmload-0.9.6-solaris.patch b/x11-plugins/wmload/files/wmload-0.9.6-solaris.patch
index 210b28419fa8..ec5e4c84abb2 100644
--- a/x11-plugins/wmload/files/wmload-0.9.6-solaris.patch
+++ b/x11-plugins/wmload/files/wmload-0.9.6-solaris.patch
@@ -1,7 +1,7 @@
* original: http://www.rampant.org/~dp/software/wmload.solaris.patch
---- wmload.c
-+++ wmload.c
+--- a/wmload.c
++++ b/wmload.c
@@ -6,6 +6,11 @@
#include <math.h>
#include <fcntl.h>
diff --git a/x11-plugins/wmload/wmload-0.9.7-r1.ebuild b/x11-plugins/wmload/wmload-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..167a3e4ade6a
--- /dev/null
+++ b/x11-plugins/wmload/wmload-0.9.7-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="yet another dock application showing a system load gauge"
+HOMEPAGE="https://www.dockapps.net/wmload"
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux ~ppc ~sparc ~sparc-solaris ~x86 ~x86-linux ~x64-solaris ~x86-solaris"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.9.6-solaris.patch )
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+
+ dodoc README
+ domenu "${FILESDIR}"/${PN}.desktop
+}