summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 08:04:14 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:10:29 +0100
commit0b0c7003dcb76d063147c071fcd78c0b391c8248 (patch)
tree303502d916d4b248472756b166366d6a7b29fc3e /x11-plugins
parentx11-plugins/gkrellaclock: tidy up patches (diff)
downloadgentoo-0b0c7003dcb76d063147c071fcd78c0b391c8248.tar.gz
gentoo-0b0c7003dcb76d063147c071fcd78c0b391c8248.tar.bz2
gentoo-0b0c7003dcb76d063147c071fcd78c0b391c8248.zip
x11-plugins/gkrellm-vaiobright: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrellm-vaiobright/files/gkrellm-vaiobright-2.5-fixinfo.patch10
-rw-r--r--x11-plugins/gkrellm-vaiobright/files/gkrellm-vaiobright-2.5-textrel.patch8
-rw-r--r--x11-plugins/gkrellm-vaiobright/gkrellm-vaiobright-2.5-r2.ebuild12
3 files changed, 16 insertions, 14 deletions
diff --git a/x11-plugins/gkrellm-vaiobright/files/gkrellm-vaiobright-2.5-fixinfo.patch b/x11-plugins/gkrellm-vaiobright/files/gkrellm-vaiobright-2.5-fixinfo.patch
index f2e4ac4c56e0..3ecf0e058ff7 100644
--- a/x11-plugins/gkrellm-vaiobright/files/gkrellm-vaiobright-2.5-fixinfo.patch
+++ b/x11-plugins/gkrellm-vaiobright/files/gkrellm-vaiobright-2.5-fixinfo.patch
@@ -1,6 +1,5 @@
-diff -ur vaiobright-2.5/readme vaiobright-2.5-infofix/readme
---- vaiobright-2.5/README 2004-03-20 13:58:13.000000000 -0500
-+++ vaiobright-2.5-infofix/README 2004-03-20 13:59:30.000000000 -0500
+--- a/README
++++ b/README
@@ -28,6 +28,7 @@
bright or max dark depending on the current value.
@@ -9,9 +8,8 @@ diff -ur vaiobright-2.5/readme vaiobright-2.5-infofix/readme
2.5 Sun 20 Oct 2002 Removed need for external helper applications
entirely. SonyPI is now required, but no suid
or spicctrl binaries are needed.
-diff -ur vaiobright-2.5/vaiobright.c vaiobright-2.5-infofix/vaiobright.c
---- vaiobright-2.5/vaiobright.c 2002-10-20 19:22:26.000000000 -0400
-+++ vaiobright-2.5-infofix/vaiobright.c 2004-03-20 12:55:38.000000000 -0500
+--- a/vaiobright.c
++++ b/vaiobright.c
@@ -422,21 +422,9 @@
(GtkSignalFunc) vaiobright_toggle_toggled, REVERSE_TOGGLE);
diff --git a/x11-plugins/gkrellm-vaiobright/files/gkrellm-vaiobright-2.5-textrel.patch b/x11-plugins/gkrellm-vaiobright/files/gkrellm-vaiobright-2.5-textrel.patch
index 4cdaa1dd4c8e..2437cf8a430b 100644
--- a/x11-plugins/gkrellm-vaiobright/files/gkrellm-vaiobright-2.5-textrel.patch
+++ b/x11-plugins/gkrellm-vaiobright/files/gkrellm-vaiobright-2.5-textrel.patch
@@ -1,5 +1,5 @@
---- vaiobright-2.5/Makefile.orig 2002-10-20 16:52:19.000000000 -0600
-+++ vaiobright-2.5/Makefile 2007-02-21 08:55:39.000000000 -0600
+--- a/Makefile
++++ b/Makefile
@@ -1,10 +1,11 @@
HOME = .
PREFIX = /usr
@@ -7,11 +7,11 @@
+CC ?= cc
INCLUDE = -I./ -I${PREFIX}/include
-OPTS = -shared `pkg-config gtk+-2.0 --cflags`
-+CFLAGS += -shared `pkg-config gtk+-2.0 --cflags` -fPIC
++CFLAGS += -shared `${PKG_CONFIG} gtk+-2.0 --cflags` -fPIC
+LDFLAGS += -shared -fPIC
DEFINES =
-LIBS = `pkg-config gtk+-2.0 --cflags`
-+LIBS = `pkg-config gtk+-2.0 --libs`
++LIBS = `${PKG_CONFIG} gtk+-2.0 --libs`
GKVO = vaiobright.o
GKV = vaiobright.so
diff --git a/x11-plugins/gkrellm-vaiobright/gkrellm-vaiobright-2.5-r2.ebuild b/x11-plugins/gkrellm-vaiobright/gkrellm-vaiobright-2.5-r2.ebuild
index efe7712aba51..e9d8482c1f47 100644
--- a/x11-plugins/gkrellm-vaiobright/gkrellm-vaiobright-2.5-r2.ebuild
+++ b/x11-plugins/gkrellm-vaiobright/gkrellm-vaiobright-2.5-r2.ebuild
@@ -1,28 +1,32 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit gkrellm-plugin
+inherit gkrellm-plugin toolchain-funcs
MY_P=${P/gkrellm-/}
DESCRIPTION="Superslim VAIO LCD Brightness Control Plugin for Gkrellm"
SRC_URI="http://nerv-un.net/~dragorn/code/${MY_P}.tar.gz"
HOMEPAGE="http://nerv-un.net/~dragorn/"
+S="${WORKDIR}"/${MY_P}
LICENSE="GPL-2"
SLOT="2"
KEYWORDS="~amd64 x86"
-IUSE=""
RDEPEND="app-admin/gkrellm:2[X]"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-S=${WORKDIR}/${MY_P}
PATCHES=(
"${FILESDIR}"/${P}-textrel.patch
"${FILESDIR}"/${P}-fixinfo.patch
)
PLUGIN_SO=( vaiobright$(get_modname) )
+
+src_configure() {
+ tc-export PKG_CONFIG
+}