summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-07-07 09:59:17 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-07-07 09:59:32 +0200
commit120f954e4cfe7b64cc162e399f60955d0a37e631 (patch)
tree8ee902d0bc4fa9284fd5de88a08d9f1b03970ee0 /x11-plugins
parentprofiles/arch/arm64: mask nautilus[previewer] (diff)
downloadgentoo-120f954e4cfe7b64cc162e399f60955d0a37e631.tar.gz
gentoo-120f954e4cfe7b64cc162e399f60955d0a37e631.tar.bz2
gentoo-120f954e4cfe7b64cc162e399f60955d0a37e631.zip
x11-plugins/gkrellm-cpupower: Bump to version 0.2 (bug #622736).
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrellm-cpupower/Manifest1
-rw-r--r--x11-plugins/gkrellm-cpupower/gkrellm-cpupower-0.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-cpupower/Manifest b/x11-plugins/gkrellm-cpupower/Manifest
index e1ef624e617c..846b7cdba2d1 100644
--- a/x11-plugins/gkrellm-cpupower/Manifest
+++ b/x11-plugins/gkrellm-cpupower/Manifest
@@ -1 +1,2 @@
DIST gkrellm2-cpupower-0.1.6.tar.gz 14390 SHA256 85a6c24976f9e0bac69fae0d161a00545078623765d76128cce587d67452305f SHA512 eb55a30614f5e4ae9514516749f34dbf6bd409148e967f2933d49f3d2bb6938535900101ed27dff132edd79b7cfa2f7244bb6f87e09b555e7536c8f74d020b01 WHIRLPOOL afb764799d1d926afb3cadd0e928a2da06d7c7728dd0cfe73ea0843bec5d4312ea076abaf7dad83ba6487f33680956ecc4eaeb9e806b6f4f5aa407fb469c0f81
+DIST gkrellm2-cpupower-0.2.tar.gz 14274 SHA256 d6c632c079c5782564431f78dfc21d81f74ee46d19c43c0ae38be5a279305a0d SHA512 80cf86548c8329af41462cb5cdd0de67cfab05d8d9a7c3315fcc662e0b5e511ffc1f46d2eb3ccf13b9f1607c35860921658eb74970c241a4c56b74e32e4f779e WHIRLPOOL f9af36768b491e1e3ab0cded1e9bae64a93f39d1be7770ec65b0351a0b95988e54f51add849a6ea222a574863926d7d46ff2a3aee8f82f8f0cc12240c44e79b9
diff --git a/x11-plugins/gkrellm-cpupower/gkrellm-cpupower-0.2.ebuild b/x11-plugins/gkrellm-cpupower/gkrellm-cpupower-0.2.ebuild
new file mode 100644
index 000000000000..8aa8fda8a8a8
--- /dev/null
+++ b/x11-plugins/gkrellm-cpupower/gkrellm-cpupower-0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gkrellm-plugin
+
+MY_P="${P/gkrellm/gkrellm2}"
+
+DESCRIPTION="A Gkrellm2 plugin for displaying and manipulating CPU frequency"
+HOMEPAGE="https://github.com/sainsaar/gkrellm2-cpupower/"
+SRC_URI="https://github.com/sainsaar/gkrellm2-cpupower/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="
+ app-admin/sudo
+ sys-power/cpupower
+"
+
+PLUGIN_SO="cpupower.so"
+
+src_install() {
+ gkrellm-plugin_src_install
+ emake DESTDIR="${D}" install-sudo
+}
+
+pkg_postinst() {
+ echo
+ einfo "For changing the governor and CPU frequencies as a user, create the \"trusted\""
+ einfo "group, and add those users to that group who should be allowed to perform"
+ einfo "these changes."
+ echo
+}