summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2022-08-01 12:46:14 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2022-08-01 12:49:54 +0300
commit33fe42ed406c519eb6198c7d58aad75d9435011d (patch)
treeab43e9a8e38fc7fb8f428e9d8a3aac010320be5b /x11-plugins
parentsys-kernel/gentoo-sources: 5.19 branch, add genpatches (diff)
downloadgentoo-33fe42ed406c519eb6198c7d58aad75d9435011d.tar.gz
gentoo-33fe42ed406c519eb6198c7d58aad75d9435011d.tar.bz2
gentoo-33fe42ed406c519eb6198c7d58aad75d9435011d.zip
x11-plugins/e16-epplets: fix build with musl
Add missing <sys/select.h> for fd_set. Closes: https://bugs.gentoo.org/833163 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/e16-epplets/e16-epplets-0.17.ebuild2
-rw-r--r--x11-plugins/e16-epplets/files/e16-epplets-0.17-musl.patch60
2 files changed, 62 insertions, 0 deletions
diff --git a/x11-plugins/e16-epplets/e16-epplets-0.17.ebuild b/x11-plugins/e16-epplets/e16-epplets-0.17.ebuild
index a9d646dbd7f3..643433afff87 100644
--- a/x11-plugins/e16-epplets/e16-epplets-0.17.ebuild
+++ b/x11-plugins/e16-epplets/e16-epplets-0.17.ebuild
@@ -31,6 +31,8 @@ DEPEND="${CDEPEND}
x11-base/xorg-proto
"
+PATCHES=( "${FILESDIR}/${PN}-0.17-musl.patch" )
+
src_configure() {
local myconf=(
$(use_enable cdaudio)
diff --git a/x11-plugins/e16-epplets/files/e16-epplets-0.17-musl.patch b/x11-plugins/e16-epplets/files/e16-epplets-0.17-musl.patch
new file mode 100644
index 000000000000..d6c2a6bbd3a6
--- /dev/null
+++ b/x11-plugins/e16-epplets/files/e16-epplets-0.17-musl.patch
@@ -0,0 +1,60 @@
+commit c3dcab92ff903422814573d6315ed2a1417080f6
+Author: Andrew Savchenko <bircoph@gentoo.org>
+Date: Mon Aug 1 12:03:51 2022 +0300
+
+ Include <sys/select.h> for fd_set
+
+ When fd_set is used <sys/select.h> should be included.
+ On glibc it is done implicitly via other headers,
+ on musl it must be explicitly provided.
+
+ Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
+
+diff --git a/api/epplet.c b/api/epplet.c
+index b6a7907..b74a4bc 100644
+--- a/api/epplet.c
++++ b/api/epplet.c
+@@ -3,6 +3,7 @@
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <sys/resource.h>
++#include <sys/select.h>
+ #include <sys/utsname.h>
+ #include <signal.h>
+ #include <sys/time.h>
+diff --git a/epplets/E-Pinger.c b/epplets/E-Pinger.c
+index 7187315..d397063 100644
+--- a/epplets/E-Pinger.c
++++ b/epplets/E-Pinger.c
+@@ -32,6 +32,7 @@
+
+ #include <errno.h>
+ #include <signal.h>
++#include <sys/select.h>
+ #include <sys/wait.h>
+
+ #include "config.h"
+diff --git a/epplets/E-SD.c b/epplets/E-SD.c
+index cd92fa3..d3b6b93 100644
+--- a/epplets/E-SD.c
++++ b/epplets/E-SD.c
+@@ -19,6 +19,7 @@
+ */
+ #include <esd.h>
+ #include <fcntl.h>
++#include <sys/select.h>
+
+ #include "config.h"
+ #include "epplet.h"
+diff --git a/epplets/E-ScreenShoot_ftp.c b/epplets/E-ScreenShoot_ftp.c
+index 377e7ee..ae40ca7 100644
+--- a/epplets/E-ScreenShoot_ftp.c
++++ b/epplets/E-ScreenShoot_ftp.c
+@@ -5,6 +5,7 @@
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <stdarg.h>
++#include <sys/select.h>
+
+ #include "E-ScreenShoot_ftp.h"
+