summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-03-01 16:05:58 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-03-01 16:12:43 +0100
commit47ccf9e869ba4e2c45d7c97aca8345d7981f341a (patch)
treef7ff3ba68acf86a7980d30dedd06ba7fc7e90765 /x11-plugins
parentx11-plugins/wmbinclock: fix build with -fno-common (diff)
downloadgentoo-47ccf9e869ba4e2c45d7c97aca8345d7981f341a.tar.gz
gentoo-47ccf9e869ba4e2c45d7c97aca8345d7981f341a.tar.bz2
gentoo-47ccf9e869ba4e2c45d7c97aca8345d7981f341a.zip
x11-plugins/wmsysmon: fix build with -fno-common
Closes: https://bugs.gentoo.org/707178 Package-Manager: Portage-2.3.90, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmsysmon/files/wmsysmon-0.7.8-gcc-10.patch23
-rw-r--r--x11-plugins/wmsysmon/wmsysmon-0.7.8.ebuild1
2 files changed, 24 insertions, 0 deletions
diff --git a/x11-plugins/wmsysmon/files/wmsysmon-0.7.8-gcc-10.patch b/x11-plugins/wmsysmon/files/wmsysmon-0.7.8-gcc-10.patch
new file mode 100644
index 000000000000..e9477899b1b9
--- /dev/null
+++ b/x11-plugins/wmsysmon/files/wmsysmon-0.7.8-gcc-10.patch
@@ -0,0 +1,23 @@
+diff -Naur src.orig/wmgeneral.h src/wmgeneral.h
+--- src.orig/wmgeneral.h 2017-12-06 15:00:16.000000000 +0100
++++ src/wmgeneral.h 2020-03-01 16:03:18.293199660 +0100
+@@ -38,7 +38,7 @@
+ /* Global variable */
+ /*******************/
+
+-Display *display;
++extern Display *display;
+
+ /***********************/
+ /* Function Prototypes */
+diff -Naur src.orig/wmsysmon.c src/wmsysmon.c
+--- src.orig/wmsysmon.c 2017-12-06 15:00:16.000000000 +0100
++++ src/wmsysmon.c 2020-03-01 16:03:32.992203044 +0100
+@@ -138,6 +138,7 @@
+ time_t curtime;
+ time_t prevtime;
+
++Display *display;
+
+ kernel_versions Get_Kernel_version(void);
+ void usage(void);
diff --git a/x11-plugins/wmsysmon/wmsysmon-0.7.8.ebuild b/x11-plugins/wmsysmon/wmsysmon-0.7.8.ebuild
index b01c8bde4910..4a1faee41b23 100644
--- a/x11-plugins/wmsysmon/wmsysmon-0.7.8.ebuild
+++ b/x11-plugins/wmsysmon/wmsysmon-0.7.8.ebuild
@@ -18,6 +18,7 @@ DEPEND="x11-libs/libX11
x11-libs/libXpm"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-gcc-10.patch )
DOCS=( ../ChangeLog ../README )
S=${WORKDIR}/${P}/src