summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-21 22:48:03 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-07-28 12:00:53 +0200
commit4da8e7c1c421da4ee8aafbf73031e42d2043201c (patch)
tree8b8ef5fa9938b31a639aeb0d3f1ef7ec7b668f3f /x11-plugins
parentx11-plugins/wmclock: add EAPI7 ebuild (diff)
downloadgentoo-4da8e7c1c421da4ee8aafbf73031e42d2043201c.tar.gz
gentoo-4da8e7c1c421da4ee8aafbf73031e42d2043201c.tar.bz2
gentoo-4da8e7c1c421da4ee8aafbf73031e42d2043201c.zip
x11-plugins/wmclockmon: EAPI7, improve ebuild
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmclockmon/wmclockmon-0.8.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-plugins/wmclockmon/wmclockmon-0.8.1-r1.ebuild b/x11-plugins/wmclockmon/wmclockmon-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..27a55ba45c25
--- /dev/null
+++ b/x11-plugins/wmclockmon/wmclockmon-0.8.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="a nice digital clock with 7 different styles either in LCD or LED style"
+HOMEPAGE="http://tnemeth.free.fr/projets/dockapps.html"
+SRC_URI="mirror://debian/pool/main/w/${PN}/${PN}_${PV}-1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libICE"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ x11-libs/libXt"
+
+PATCHES=( "${FILESDIR}"/${P}-gtk.patch )
+
+DOCS=( AUTHORS BUGS ChangeLog NEWS README THANKS TODO \
+ doc/sample2.wmclockmonrc doc/sample1.wmclockmonrc )
+
+src_install() {
+ default
+ newdoc debian/changelog ChangeLog.debian
+}