summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-22 13:00:27 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-07-26 22:28:38 +0200
commit4efbf3ca123ed0eaf7a7441da3abbbe486268f46 (patch)
treefb311671a4374ea61133780e7fa13e9a6423ed25 /x11-plugins
parentx11-plugins/wmdiskmon: EAPI7, improve ebuild (diff)
downloadgentoo-4efbf3ca123ed0eaf7a7441da3abbbe486268f46.tar.gz
gentoo-4efbf3ca123ed0eaf7a7441da3abbbe486268f46.tar.bz2
gentoo-4efbf3ca123ed0eaf7a7441da3abbbe486268f46.zip
x11-plugins/wmdots: EAPI7, improve ebuild
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmdots/wmdots-0.2_beta-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-plugins/wmdots/wmdots-0.2_beta-r1.ebuild b/x11-plugins/wmdots/wmdots-0.2_beta-r1.ebuild
new file mode 100644
index 000000000000..4f65793c9002
--- /dev/null
+++ b/x11-plugins/wmdots/wmdots-0.2_beta-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="multishape 3d rotating dots"
+HOMEPAGE="https://www.dockapps.net/wmdots"
+SRC_URI="https://www.dockapps.net/download/${P/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${P}-stringh.patch
+ sed -e "s:cc:$(tc-getCC):g" \
+ -e "s:-g -O2:${CFLAGS}:g" -i Makefile || die
+
+ #Fix compilation target
+ sed -e "s:wmifs:wmdots:" -i Makefile || die
+
+ #Honour Gentoo LDFLAGS, see bug #336982
+ sed -e "s:-o wmdots:\$(LDFLAGS) -o wmdots:" -i Makefile || die
+}
+
+src_compile() {
+ emake clean
+ emake LIBDIR="-L/usr/$(get_libdir)"
+}
+
+src_install() {
+ dobin wmdots
+}