summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-04-02 15:30:40 +0200
committerSam James <sam@gentoo.org>2022-04-21 20:54:37 +0100
commit58141c64845cfb4ecaf38bb797397a320efa62ef (patch)
tree0419f299fb38bf8e4797830399bd0da9f8d58f01 /x11-plugins
parentx11-plugins/gkrellsun: update EAPI 6 -> 8 (diff)
downloadgentoo-58141c64845cfb4ecaf38bb797397a320efa62ef.tar.gz
gentoo-58141c64845cfb4ecaf38bb797397a320efa62ef.tar.bz2
gentoo-58141c64845cfb4ecaf38bb797397a320efa62ef.zip
x11-plugins/gkrellweather: update EAPI 6 -> 8
Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrellweather/files/gkrellweather-2.0.8-r2-makefile-fixes.patch24
-rw-r--r--x11-plugins/gkrellweather/gkrellweather-2.0.8-r2.ebuild46
2 files changed, 70 insertions, 0 deletions
diff --git a/x11-plugins/gkrellweather/files/gkrellweather-2.0.8-r2-makefile-fixes.patch b/x11-plugins/gkrellweather/files/gkrellweather-2.0.8-r2-makefile-fixes.patch
new file mode 100644
index 000000000000..aa35e565e508
--- /dev/null
+++ b/x11-plugins/gkrellweather/files/gkrellweather-2.0.8-r2-makefile-fixes.patch
@@ -0,0 +1,24 @@
+Respect user's pkg-config, don't call gcc directly
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,9 @@
+ PKGNAME = gkrellweather
+ VERSION = 2.0.8
+-CFLAGS = -O2 -std=gnu99 -Wall -fPIC `pkg-config gtk+-2.0 --cflags`
+-LIBS = `pkg-config gtk+-2.0 --libs`
++PKG_CONFIG ?= pkg-config
++GTK_INCLUDE = $(shell ${PKG_CONFIG} gtk+-2.0 --cflags)
++CFLAGS = -std=gnu99 -fPIC $(GTK_INCLUDE)
++LIBS = $(shell ${PKG_CONFIG} gtk+-2.0 --libs)
+ LFLAGS = -shared
+ PREFIX = /usr/local
+
+@@ -16,7 +18,7 @@ endif
+ CFLAGS += -DPACKAGE="\"$(PKGNAME)\""
+ export PKGNAME LOCALEDIR
+
+-CC = gcc
++CC = $(CC)
+
+ OBJS = gkrellweather.o
+
diff --git a/x11-plugins/gkrellweather/gkrellweather-2.0.8-r2.ebuild b/x11-plugins/gkrellweather/gkrellweather-2.0.8-r2.ebuild
new file mode 100644
index 000000000000..1a70885d8d3c
--- /dev/null
+++ b/x11-plugins/gkrellweather/gkrellweather-2.0.8-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="GKrellM2 Plugin that monitors a METAR station and displays weatherinfo"
+HOMEPAGE="https://sites.google.com/site/makovick/gkrellm-plugins"
+SRC_URI="https://sites.google.com/site/makovick/projects/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ app-admin/gkrellm:2[X]
+ dev-lang/perl
+ net-misc/wget
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-Respect-LDFLAGS.patch
+ "${FILESDIR}"/${P}-Move-GrabWeather.patch
+ "${FILESDIR}"/${P}-update-locations.patch
+ "${FILESDIR}"/${P}-r2-makefile-fixes.patch
+)
+
+src_configure() {
+ append-cflags $($(tc-getPKG_CONFIG) --cflags gtk+-2.0)
+ append-flags -fPIC
+}
+
+src_compile() {
+ tc-export PKG_CONFIG
+ emake PREFIX="${EPREFIX}"/usr CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ gkrellm-plugin_src_install
+
+ exeinto /usr/libexec/gkrellweather
+ doexe GrabWeather
+}