summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-01-30 09:54:48 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-01-30 09:54:48 +0100
commit6706ede2c1adc7783e6ed9c58eb5847b7d00c635 (patch)
treeccf91e3963fdc3f6224363fbec1dda011d5f40ac /x11-plugins
parentapp-emulation/simh: bump up to 3.11.0, take package (diff)
downloadgentoo-6706ede2c1adc7783e6ed9c58eb5847b7d00c635.tar.gz
gentoo-6706ede2c1adc7783e6ed9c58eb5847b7d00c635.tar.bz2
gentoo-6706ede2c1adc7783e6ed9c58eb5847b7d00c635.zip
x11-plugins/wmcube: fix build with -fno-common
Closes: https://bugs.gentoo.org/706892 Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmcube/files/wmcube-1.0.2-gcc-10.patch21
-rw-r--r--x11-plugins/wmcube/wmcube-1.0.2.ebuild9
2 files changed, 29 insertions, 1 deletions
diff --git a/x11-plugins/wmcube/files/wmcube-1.0.2-gcc-10.patch b/x11-plugins/wmcube/files/wmcube-1.0.2-gcc-10.patch
new file mode 100644
index 000000000000..5beb41552562
--- /dev/null
+++ b/x11-plugins/wmcube/files/wmcube-1.0.2-gcc-10.patch
@@ -0,0 +1,21 @@
+--- a/wmgeneral/wmgeneral.c
++++ b/wmgeneral/wmgeneral.c
+@@ -45,6 +45,7 @@ Window iconwin, win;
+ GC NormalGC;
+ XpmIcon wmgen;
+ Pixmap pixmask;
++Display *display;
+
+ /*****************/
+ /* Mouse Regions */
+--- a/wmgeneral/wmgeneral.h
++++ b/wmgeneral/wmgeneral.h
+@@ -21,7 +21,7 @@ typedef struct {
+ /* Global variable */
+ /*******************/
+
+-Display *display;
++extern Display *display;
+
+ /***********************/
+ /* Function Prototypes */
diff --git a/x11-plugins/wmcube/wmcube-1.0.2.ebuild b/x11-plugins/wmcube/wmcube-1.0.2.ebuild
index cca916b659af..1a9633dc99cc 100644
--- a/x11-plugins/wmcube/wmcube-1.0.2.ebuild
+++ b/x11-plugins/wmcube/wmcube-1.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -26,6 +26,13 @@ DOCS=(
)
S="${WORKDIR}/${P}/wmcube"
+src_prepare() {
+ default
+
+ pushd "${WORKDIR}"/${P} || die
+ eapply "${FILESDIR}"/${P}-gcc-10.patch
+}
+
src_compile() {
emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
}