summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-06-06 23:31:47 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-06-06 23:31:47 +0200
commit70e472c4b06ac7d705f9ce33f2dae7189032613d (patch)
treed2d87b4fddcd4c7a98cc7584331e0d96f20c03b9 /x11-plugins
parentdev-lua/lua-zlib: Remove old (diff)
downloadgentoo-70e472c4b06ac7d705f9ce33f2dae7189032613d.tar.gz
gentoo-70e472c4b06ac7d705f9ce33f2dae7189032613d.tar.bz2
gentoo-70e472c4b06ac7d705f9ce33f2dae7189032613d.zip
x11-plugins/pidgin-xmpp-receipts: Version bump to 0.8
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-xmpp-receipts/Manifest1
-rw-r--r--x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-xmpp-receipts/Manifest b/x11-plugins/pidgin-xmpp-receipts/Manifest
index 217e00f333ae..47d6c29fb110 100644
--- a/x11-plugins/pidgin-xmpp-receipts/Manifest
+++ b/x11-plugins/pidgin-xmpp-receipts/Manifest
@@ -1 +1,2 @@
DIST pidgin-xmpp-receipts-0.6.tar.gz 15946 SHA256 a7aa5ab7375dc996d769dd83fdf6f7c68ac6ef9fd25cfb04eb7bf2becd381174 SHA512 160270206d0d6394bddaa15ca59896756ab3a546f7c74cc9e3d4ec634f70b829ae3b013ee6086a5d4a5376b7d2b81341c44c3ef0ecab2a66d612b96fd37dfeff WHIRLPOOL 00349394518cb44d3a25c0ed66b0e0446ca9bdeddb68b818e1c4b493e38ee22a550d27e4a9170360f73c9ec449a8602c2ab2a0f451411862e32cd33d8782a94f
+DIST pidgin-xmpp-receipts-0.8.tar.gz 16021 SHA256 0bceff237c6eb23e0564f7560d0ff491b37c01c8f6e3a3a7d8c4fdd6781d6524 SHA512 04113236d46066211d7e0f3c66f4bf1b6fb8a33ac675203f3cff15300eb97ffd3ee627e03fcc3ab3d1e9431fc107a9f7e9fca319f3debb773603d311b167b5a8 WHIRLPOOL 72423367225e4a80b16d6bea776ce411324b888f1a77e49e2a4e7a12d92662071a9d8f7bd12d6b2292ee6fc54bbae4aa9837bab14d40ec18f2e624a1e651882e
diff --git a/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild b/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild
new file mode 100644
index 000000000000..ecb5f4ae29ff
--- /dev/null
+++ b/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vcs-snapshot toolchain-funcs
+
+DESCRIPTION="Implementation of xmpp message delivery receipts (XEP-0184) for Pidgin"
+HOMEPAGE="https://github.com/noonien-d/pidgin-xmpp-receipts"
+SRC_URI="https://github.com/noonien-d/pidgin-xmpp-receipts/archive/release_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="net-im/pidgin[gtk]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_compile() {
+ GTK_PIDGIN_INCLUDES=$(pkg-config --cflags gtk+-2.0 pidgin)
+ $(tc-getCC) ${LDFLAGS} -shared ${CFLAGS} -fpic ${GTK_PIDGIN_INCLUDES} -o ${PN/pidgin-/}.so ${PN/pidgin-/}.c || die
+}
+
+src_install() {
+ PLUGIN_DIR_PIDGIN=$(pkg-config --variable=plugindir pidgin)
+ dodir "${PLUGIN_DIR_PIDGIN}"
+ insinto "${PLUGIN_DIR_PIDGIN}"
+ doins ${PN/pidgin-/}.so
+}