summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-05-16 10:23:01 +0100
committerMarek Szuba <marecki@gentoo.org>2022-05-16 10:31:46 +0100
commit839006b40a5fb765b45be47a0a556df8aca0daf0 (patch)
tree78c286ec9760c08ac0ffa47a6ebfd16ded6751e6 /x11-plugins
parentapp-containers/apptainer: add 1.0.2 (diff)
downloadgentoo-839006b40a5fb765b45be47a0a556df8aca0daf0.tar.gz
gentoo-839006b40a5fb765b45be47a0a556df8aca0daf0.tar.bz2
gentoo-839006b40a5fb765b45be47a0a556df8aca0daf0.zip
x11-plugins/vicious: add 2.5.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/vicious/Manifest1
-rw-r--r--x11-plugins/vicious/vicious-2.5.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/x11-plugins/vicious/Manifest b/x11-plugins/vicious/Manifest
index 4bd73af4e091..e69f05a97f78 100644
--- a/x11-plugins/vicious/Manifest
+++ b/x11-plugins/vicious/Manifest
@@ -1 +1,2 @@
DIST vicious-2.5.0.tar.gz 67557 BLAKE2B ffbc1b3c0e32b554cc367a51e5e17130e1b9f7fed2e8505aaa1845719ecd6d465d43ba839ac3a9b73a87e43ff3144c2074f3750d5f67b516d033a74144e9e12f SHA512 deb21587d1d7f2e6e4dd77c74abbfa337acf6c99ef9bebc0e505f1508afc6e3b03f043a639f866fcda0191447c103d3fba51376682201482fb669a263321dee5
+DIST vicious-2.5.1.tar.gz 68635 BLAKE2B fa952f878140e76a44bde98ab928fe2a01a12f0e931a4f8ee366acba584661a0e42b150d4f69bfaaf7c58c68d57d2e261d8b586fb1abbd329d9f30fe90c2e21d SHA512 63de92a4e7d666d5737bfc0f50857c48f40818e5f1cf81ba672284db764c68d151f73afd6507b7392b38ae91cf1d18104284618430d15dd8837c56a0283571fe
diff --git a/x11-plugins/vicious/vicious-2.5.1.ebuild b/x11-plugins/vicious/vicious-2.5.1.ebuild
new file mode 100644
index 000000000000..e52e28e1f48e
--- /dev/null
+++ b/x11-plugins/vicious/vicious-2.5.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Modular widget library for x11-wm/awesome"
+HOMEPAGE="https://github.com/vicious-widgets/vicious"
+SRC_URI="https://github.com/${PN}-widgets/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="contrib"
+
+RDEPEND="x11-wm/awesome"
+
+src_install() {
+ insinto /usr/share/awesome/lib/vicious
+ doins -r widgets spawn.lua helpers.lua init.lua
+
+ if use contrib; then
+ insinto /usr/share/awesome/lib/vicious/contrib
+ doins contrib/*.lua
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ # Note that as of 2.5.1 this list may or may not be incomplete - it has been produced
+ # only by searching for occurrences of vicious.spawn (the recommended way of calling
+ # external helpers because it supports async) and popen (still used by many contrib widgets).
+ # Moreover, dependencies of all non-Linux widgets have been excluded on purpose.
+ optfeature_header "These widgets need some dependencies:"
+ optfeature "cmus" "media-sound/cmus"
+ optfeature "fs" "sys-apps/coreutils" # df
+ optfeature "gmail" "net-misc/curl"
+ optfeature "hddtemp" "net-misc/curl[telnet] app-admin/hddtemp"
+ optfeature "hwmontemp" "sys-apps/grep"
+ optfeature "mdir" "sys-apps/findutils"
+ optfeature "mpd" "net-misc/curl[telnet] media-sound/mpd"
+ optfeature "notmuch" "net-mail/notmuch"
+ optfeature "volume" "media-sound/alsa-utils" # amixer
+ optfeature "weather" "net-misc/curl"
+ optfeature "wifi" "net-wireless/wireless-tools"
+ optfeature "wifiiw" "net-wireless/iw"
+ if use contrib; then
+ optfeature "contrib/btc" "net-misc/curl"
+ optfeature "contrib/buildbot" "net-misc/curl"
+ optfeature "contrib/countfiles" "sys-apps/findutils"
+ optfeature "contrib/mpc" "media-sound/mpc"
+ optfeature "contrib/openweather" "net-misc/curl"
+ optfeature "contrib/netcfg" "sys-apps/coreutils" # ls
+ optfeature "contrib/nvinf" "x11-drivers/nvidia-drivers" # nvidia-settings
+ # ossvol needs 'ossmix' - not packaged?
+ optfeature "contrib/pulse" "media-sound/pulseaudio" # pacmd
+ optfeature "contrib/rss" "net-misc/curl"
+ optfeature "contrib/sensors" "sys-apps/lm-sensors"
+ optfeature "contrib/wpa" "net-wireless/wpa_supplicant" # wpa-cli
+ fi
+ elog
+}