summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-22 14:28:25 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-07-26 22:30:52 +0200
commit84b538f61550bf925d55d0b89b346746642f344a (patch)
treeff09a87bc3387b0851eae992b42957099918b843 /x11-plugins
parentx11-plugins/wmfire: EAPI7, improve ebuild (diff)
downloadgentoo-84b538f61550bf925d55d0b89b346746642f344a.tar.gz
gentoo-84b538f61550bf925d55d0b89b346746642f344a.tar.bz2
gentoo-84b538f61550bf925d55d0b89b346746642f344a.zip
x11-plugins/wmfishtime: EAPI7, improve ebuild
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmfishtime/files/wmfishtime-1.24-no_display.patch4
-rw-r--r--x11-plugins/wmfishtime/wmfishtime-1.24-r3.ebuild38
2 files changed, 40 insertions, 2 deletions
diff --git a/x11-plugins/wmfishtime/files/wmfishtime-1.24-no_display.patch b/x11-plugins/wmfishtime/files/wmfishtime-1.24-no_display.patch
index a991cdab934b..8ae99b049f69 100644
--- a/x11-plugins/wmfishtime/files/wmfishtime-1.24-no_display.patch
+++ b/x11-plugins/wmfishtime/files/wmfishtime-1.24-no_display.patch
@@ -1,5 +1,5 @@
---- fishmon.c.orig 2010-06-27 18:38:42.000000000 +0200
-+++ fishmon.c 2010-06-27 18:40:56.000000000 +0200
+--- a/fishmon.c 2010-06-27 18:38:42.000000000 +0200
++++ b/fishmon.c 2010-06-27 18:40:56.000000000 +0200
@@ -152,6 +152,8 @@
int main(int argc, char **argv)
diff --git a/x11-plugins/wmfishtime/wmfishtime-1.24-r3.ebuild b/x11-plugins/wmfishtime/wmfishtime-1.24-r3.ebuild
new file mode 100644
index 000000000000..05564bfd1885
--- /dev/null
+++ b/x11-plugins/wmfishtime/wmfishtime-1.24-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A fun clock applet for your desktop featuring swimming fish"
+HOMEPAGE="http://www.ne.jp/asahi/linux/timecop"
+SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-gtk.patch
+ "${FILESDIR}"/${P}-no_display.patch )
+
+DOCS=( ALL_I_GET_IS_A_GRAY_BOX AUTHORS ChangeLog CODING README )
+
+src_prepare() {
+ default
+ sed -i -e "s/\$(CC)/& \$(LDFLAGS)/" Makefile || die #331891
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ einstalldocs
+}