summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-22 14:49:43 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-07-26 22:30:52 +0200
commit8b3c624a17d4cceb69f3b99c074d8ebd8f70d0c5 (patch)
tree1359cade80747a58f0778211f00f473fd5619451 /x11-plugins
parentx11-plugins/wmforkplop: EAPI7, improve ebuild (diff)
downloadgentoo-8b3c624a17d4cceb69f3b99c074d8ebd8f70d0c5.tar.gz
gentoo-8b3c624a17d4cceb69f3b99c074d8ebd8f70d0c5.tar.bz2
gentoo-8b3c624a17d4cceb69f3b99c074d8ebd8f70d0c5.zip
x11-plugins/wmfrog: EAPI7, improve ebuild
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmfrog/wmfrog-0.3.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/wmfrog/wmfrog-0.3.1-r1.ebuild b/x11-plugins/wmfrog/wmfrog-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..2951a537833d
--- /dev/null
+++ b/x11-plugins/wmfrog/wmfrog-0.3.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="a weather application, it shows the weather in a graphical way"
+HOMEPAGE="http://wiki.colar.net/wmfrog_dockapp"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+S="${WORKDIR}/Src"
+
+DOCS=( ../{CHANGES,HINTS} )
+
+src_prepare() {
+ default
+ emake clean
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" INCDIR="" \
+ LIBDIR="" SYSTEM="${LDFLAGS}"
+}