summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-04-13 12:58:46 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-04-13 12:58:56 +0200
commit8de49eb6cc251cd3b345022991a51ede9e98e0b5 (patch)
tree0239a288c3e8e0e56f7570b4a5477487f57d75fa /x11-plugins
parentmedia-libs/jasper: add note about heif use flag (diff)
downloadgentoo-8de49eb6cc251cd3b345022991a51ede9e98e0b5.tar.gz
gentoo-8de49eb6cc251cd3b345022991a51ede9e98e0b5.tar.bz2
gentoo-8de49eb6cc251cd3b345022991a51ede9e98e0b5.zip
x11-plugins/wmsysmon: add 0.8.1
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmsysmon/Manifest1
-rw-r--r--x11-plugins/wmsysmon/wmsysmon-0.8.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/wmsysmon/Manifest b/x11-plugins/wmsysmon/Manifest
index adb9c097c63d..6385c75444c2 100644
--- a/x11-plugins/wmsysmon/Manifest
+++ b/x11-plugins/wmsysmon/Manifest
@@ -1 +1,2 @@
DIST wmsysmon-0.8.0.tar.gz 21262 BLAKE2B 50c7e3149fbad711f7505558549eadede78abf4f52d5c2c6eff0bd74bbb9838f85b78d73a7021a3baf9776cdccfb2b8e621de897fdafe5a7af71cd8518933852 SHA512 af9f939de5031387abf31d7ad9b4f767056a5f0d1494ee95476fb6c3bafab95ffe78148da74bf004b40a1e0d4ace9616c272bce0f4900491c8983c34531c29e7
+DIST wmsysmon-0.8.1.tar.gz 21276 BLAKE2B 17711e383f6285bccb16eeae83bfd302e73bed4b9744aa2ef78e228ff103f2342d024668cf285578cbebb3f9cbbd14ae3b5bab26b3454bb973449cc124068f0c SHA512 d6ce023683083de292284f6e155053a6da2dad87365d63c296b857507f803426fc68880c90489c3f5bd756bf66359b5d4624e928afec9cd1d0a3d5792a3a8f2b
diff --git a/x11-plugins/wmsysmon/wmsysmon-0.8.1.ebuild b/x11-plugins/wmsysmon/wmsysmon-0.8.1.ebuild
new file mode 100644
index 000000000000..6d98e0bd7d33
--- /dev/null
+++ b/x11-plugins/wmsysmon/wmsysmon-0.8.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit toolchain-funcs
+
+DESCRIPTION="a dockapp to monitor: CPU, Memory, Uptime, IRQs, Paging and Swap activity"
+HOMEPAGE="https://github.com/voyageur/wmsysmon"
+SRC_URI="https://github.com/voyageur/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+RDEPEND="${DEPEND}"
+
+DOCS=( ../ChangeLog ../README )
+S=${WORKDIR}/${P}/src
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin wmsysmon
+ einstalldocs
+}