summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-03 23:34:32 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-04 10:15:25 +0100
commit9916796c05f54114c272a13c17505f522efef506 (patch)
tree88c32e98c81b1d7d27040756110587be29c7e961 /x11-plugins
parentx11-plugins/gkrellm-trayicons: Eclass update (diff)
downloadgentoo-9916796c05f54114c272a13c17505f522efef506.tar.gz
gentoo-9916796c05f54114c272a13c17505f522efef506.tar.bz2
gentoo-9916796c05f54114c272a13c17505f522efef506.zip
x11-plugins/gkrellmwireless: Eclass update
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrellmwireless/files/gkrellmwireless-2.0.3-fix-build-system.patch26
-rw-r--r--x11-plugins/gkrellmwireless/gkrellmwireless-2.0.3-r2.ebuild22
2 files changed, 37 insertions, 11 deletions
diff --git a/x11-plugins/gkrellmwireless/files/gkrellmwireless-2.0.3-fix-build-system.patch b/x11-plugins/gkrellmwireless/files/gkrellmwireless-2.0.3-fix-build-system.patch
new file mode 100644
index 000000000000..eb821e9b2de0
--- /dev/null
+++ b/x11-plugins/gkrellmwireless/files/gkrellmwireless-2.0.3-fix-build-system.patch
@@ -0,0 +1,26 @@
+--- a/Makefile
++++ b/Makefile
+@@ -16,12 +16,11 @@
+ GTK_CFLAGS = `$(GTK_CONFIG) --cflags`
+ GTK_LIB = `$(GTK_CONFIG) --libs`
+
+-FLAGS = -O2 -Wall -fPIC $(GTK_CFLAGS) $(GKRELLM_INCLUDE)
++CFLAGS += -Wall -fPIC
++CPPFLAGS += $(GTK_CFLAGS) $(GKRELLM_INCLUDE)
+ LIBS = $(GTK_LIB)
+ LFLAGS = -shared
+
+-CC = gcc $(CFLAGS) $(FLAGS)
+-
+ OBJS = wireless.o
+
+ PLUGIN_DIR = /usr/lib/gkrellm2/plugins
+@@ -32,7 +31,7 @@
+ all: wireless.so
+
+ wireless.so: $(OBJS)
+- $(CC) $(OBJS) -o wireless.so $(LFLAGS) $(LIBS)
++ $(CC) $(LDFLAGS) $^ -o $@ $(LFLAGS) $(LIBS)
+
+ clean:
+ rm -f *.o core *.so* *.bak *~
diff --git a/x11-plugins/gkrellmwireless/gkrellmwireless-2.0.3-r2.ebuild b/x11-plugins/gkrellmwireless/gkrellmwireless-2.0.3-r2.ebuild
index 85fd1b160794..d3956e0aa0d0 100644
--- a/x11-plugins/gkrellmwireless/gkrellmwireless-2.0.3-r2.ebuild
+++ b/x11-plugins/gkrellmwireless/gkrellmwireless-2.0.3-r2.ebuild
@@ -1,27 +1,27 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit gkrellm-plugin toolchain-funcs
-S="${WORKDIR}/${PN}"
DESCRIPTION="A plugin for GKrellM that monitors your wireless network card"
SRC_URI="http://gkrellm.luon.net/files/${P}.tar.gz"
HOMEPAGE="http://gkrellm.luon.net/gkrellmwireless.php"
-SLOT="2"
LICENSE="GPL-2"
+SLOT="2"
KEYWORDS="amd64 ~ppc ~sparc x86"
IUSE=""
-RDEPEND="app-admin/gkrellm[X]"
+RDEPEND="app-admin/gkrellm:2[X]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+PATCHES=( "${FILESDIR}"/${PN}-2.0.3-fix-build-system.patch )
-PLUGIN_SO=wireless.so
+PLUGIN_SO=( wireless$(get_modname) )
-src_prepare() {
- default
- sed -i \
- -e '/^CC =/s:gcc $(CFLAGS) $(FLAGS):'"$(tc-getCC)"' $(FLAGS) $(CFLAGS):' \
- -e '/-o wireless.so/s: : $(LDFLAGS) :' \
- Makefile || die
+src_configure() {
+ tc-export CC
}