summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-02-27 11:43:50 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-02-27 11:44:03 +0100
commita2f3c2b38d2d8d85e5f2c0a5d781bab0a2046415 (patch)
tree8e7bd8806d37285f7ec7ac3a8cd20e4709d0eaf9 /x11-plugins
parentx11-plugins/wmtimer: replace ":" as sed delimiter (diff)
downloadgentoo-a2f3c2b38d2d8d85e5f2c0a5d781bab0a2046415.tar.gz
gentoo-a2f3c2b38d2d8d85e5f2c0a5d781bab0a2046415.tar.bz2
gentoo-a2f3c2b38d2d8d85e5f2c0a5d781bab0a2046415.zip
x11-plugins/wmmoonclock: fix build with -fno-common
Closes: https://bugs.gentoo.org/707152 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmmoonclock/files/wmmoonclock-1.29-gcc-10.patch37
-rw-r--r--x11-plugins/wmmoonclock/wmmoonclock-1.29.ebuild4
2 files changed, 40 insertions, 1 deletions
diff --git a/x11-plugins/wmmoonclock/files/wmmoonclock-1.29-gcc-10.patch b/x11-plugins/wmmoonclock/files/wmmoonclock-1.29-gcc-10.patch
new file mode 100644
index 000000000000..9554254e6239
--- /dev/null
+++ b/x11-plugins/wmmoonclock/files/wmmoonclock-1.29-gcc-10.patch
@@ -0,0 +1,37 @@
+diff -Naur wmmoonclock-1.29.orig/src/xutils.c wmmoonclock-1.29/src/xutils.c
+--- wmmoonclock-1.29.orig/src/xutils.c 2017-08-15 00:32:44.000000000 +0200
++++ wmmoonclock-1.29/src/xutils.c 2020-02-27 11:42:33.266076617 +0100
+@@ -52,6 +52,13 @@
+ XpmIcon wmgen;
+ Pixmap pixmask;
+
++Display *display;
++Window Root;
++Window iconwin, win;
++int screen;
++int DisplayDepth;
++
++
+
+
+
+diff -Naur wmmoonclock-1.29.orig/src/xutils.h wmmoonclock-1.29/src/xutils.h
+--- wmmoonclock-1.29.orig/src/xutils.h 2017-08-15 00:31:51.000000000 +0200
++++ wmmoonclock-1.29/src/xutils.h 2020-02-27 11:41:58.180058348 +0100
+@@ -20,11 +20,11 @@
+ /*
+ * Global variable
+ */
+-Display *display;
+-Window Root;
+-Window iconwin, win;
+-int screen;
+-int DisplayDepth;
++extern Display *display;
++extern Window Root;
++extern Window iconwin, win;
++extern int screen;
++extern int DisplayDepth;
+
+
+
diff --git a/x11-plugins/wmmoonclock/wmmoonclock-1.29.ebuild b/x11-plugins/wmmoonclock/wmmoonclock-1.29.ebuild
index 0345f7cf9a51..9530051db958 100644
--- a/x11-plugins/wmmoonclock/wmmoonclock-1.29.ebuild
+++ b/x11-plugins/wmmoonclock/wmmoonclock-1.29.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,3 +17,5 @@ RDEPEND="x11-libs/libX11
x11-libs/libXpm"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
+
+PATCHES=( "${FILESDIR}"/${P}-gcc-10.patch )