summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-04 00:28:42 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-04 00:28:58 +0200
commita875d63b47cb68ceea0915be3e3807b8b515ed66 (patch)
tree54694821da8a85fb2f35a4e719eb65df2ae2a12e /x11-plugins
parentkde-frameworks/kcoreaddons: Add missing xdg_mimeinfo_database_update (diff)
downloadgentoo-a875d63b47cb68ceea0915be3e3807b8b515ed66.tar.gz
gentoo-a875d63b47cb68ceea0915be3e3807b8b515ed66.tar.bz2
gentoo-a875d63b47cb68ceea0915be3e3807b8b515ed66.zip
x11-plugins/pidgin-telegram: add png use flag
Closes: https://bugs.gentoo.org/735116 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-telegram/pidgin-telegram-1.4.2.ebuild6
-rw-r--r--x11-plugins/pidgin-telegram/pidgin-telegram-1.4.3.ebuild4
2 files changed, 7 insertions, 3 deletions
diff --git a/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.2.ebuild b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.2.ebuild
index 21c27ac8d19b..5d6f31afd456 100644
--- a/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.2.ebuild
+++ b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,7 +10,7 @@ SRC_URI="https://github.com/majn/telegram-purple/releases/download/v${PV}/telegr
LICENSE="GPL-2+"
KEYWORDS="amd64 x86"
SLOT="0"
-IUSE="gcrypt libressl +nls +webp"
+IUSE="gcrypt libressl +nls +png +webp"
RDEPEND="net-im/pidgin
sys-libs/zlib:=
@@ -19,6 +19,7 @@ RDEPEND="net-im/pidgin
libressl? ( dev-libs/libressl:0= )
!libressl? ( dev-libs/openssl:0= )
)
+ png? ( media-libs/libpng:0= )
webp? ( media-libs/libwebp:= )"
DEPEND="${RDEPEND}"
@@ -43,6 +44,7 @@ src_configure() {
local myeconfargs=(
$(use_enable gcrypt)
$(use_enable nls translation)
+ $(use_enable png libpng)
$(use_enable webp libwebp)
)
diff --git a/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.3.ebuild b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.3.ebuild
index dbf8c2bf6f00..a7a509ac64c1 100644
--- a/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.3.ebuild
+++ b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.3.ebuild
@@ -10,7 +10,7 @@ SRC_URI="https://github.com/majn/telegram-purple/releases/download/v${PV}/telegr
LICENSE="GPL-2+"
KEYWORDS="~amd64 ~x86"
SLOT="0"
-IUSE="gcrypt libressl +nls +webp"
+IUSE="gcrypt libressl +nls +png +webp"
RDEPEND="
net-im/pidgin
@@ -20,6 +20,7 @@ RDEPEND="
libressl? ( dev-libs/libressl:0= )
!libressl? ( dev-libs/openssl:0= )
)
+ png? ( media-libs/libpng:0= )
webp? ( media-libs/libwebp:= )
"
@@ -47,6 +48,7 @@ src_configure() {
local myeconfargs=(
$(use_enable gcrypt)
$(use_enable nls translation)
+ $(use_enable png libpng)
$(use_enable webp libwebp)
)