summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-03-01 15:59:39 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-03-01 16:12:42 +0100
commitc60da361eabe6bc3c1f213e295fa6bbe23492d3e (patch)
tree84b63518adf7ce7113bf62c952b0c95645725b69 /x11-plugins
parentmedia-tv/kodi: Fix patch reference (diff)
downloadgentoo-c60da361eabe6bc3c1f213e295fa6bbe23492d3e.tar.gz
gentoo-c60da361eabe6bc3c1f213e295fa6bbe23492d3e.tar.bz2
gentoo-c60da361eabe6bc3c1f213e295fa6bbe23492d3e.zip
x11-plugins/wmfrog: fix build with -fno-common
Closes: https://bugs.gentoo.org/707710 Package-Manager: Portage-2.3.90, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmfrog/files/wmfrog-0.3.1-gcc-10.patch36
-rw-r--r--x11-plugins/wmfrog/wmfrog-0.3.1-r1.ebuild3
2 files changed, 38 insertions, 1 deletions
diff --git a/x11-plugins/wmfrog/files/wmfrog-0.3.1-gcc-10.patch b/x11-plugins/wmfrog/files/wmfrog-0.3.1-gcc-10.patch
new file mode 100644
index 000000000000..9d25464c8eac
--- /dev/null
+++ b/x11-plugins/wmfrog/files/wmfrog-0.3.1-gcc-10.patch
@@ -0,0 +1,36 @@
+diff -Naur Src.orig/wmFrog.c Src/wmFrog.c
+--- Src.orig/wmFrog.c 2010-12-01 19:48:50.000000000 +0100
++++ Src/wmFrog.c 2020-03-01 15:54:30.428083446 +0100
+@@ -77,6 +77,12 @@
+ char* folder;
+ int needsUpdate = 1;
+
++Display *display;
++Window Root;
++Window iconwin, win;
++int screen;
++int DisplayDepth;
++
+ /*
+ * main
+ */
+diff -Naur Src.orig/xutils.h Src/xutils.h
+--- Src.orig/xutils.h 2010-08-04 20:28:46.000000000 +0200
++++ Src/xutils.h 2020-03-01 15:54:37.027084834 +0100
+@@ -18,11 +18,11 @@
+ /*
+ * Global variable
+ */
+-Display *display;
+-Window Root;
+-Window iconwin, win;
+-int screen;
+-int DisplayDepth;
++extern Display *display;
++extern Window Root;
++extern Window iconwin, win;
++extern int screen;
++extern int DisplayDepth;
+
+
+
diff --git a/x11-plugins/wmfrog/wmfrog-0.3.1-r1.ebuild b/x11-plugins/wmfrog/wmfrog-0.3.1-r1.ebuild
index b3b8ab1a8a4d..fa1b1ed45fc2 100644
--- a/x11-plugins/wmfrog/wmfrog-0.3.1-r1.ebuild
+++ b/x11-plugins/wmfrog/wmfrog-0.3.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,6 +21,7 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/Src"
+PATCHES=( "${FILESDIR}"/${P}-gcc-10.patch )
DOCS=( ../{CHANGES,HINTS} )
src_prepare() {