summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-07-26 13:10:59 +0200
committerPacho Ramos <pacho@gentoo.org>2017-07-26 13:34:40 +0200
commite8511e84423d029b9bd07969c8d1b331cb765736 (patch)
tree9e995e98fde75093f6c99ce8f75cf04a374375f9 /x11-plugins
parentx11-plugins/gkrelltop: Fix dependency on gkrellm[X] (diff)
downloadgentoo-e8511e84423d029b9bd07969c8d1b331cb765736.tar.gz
gentoo-e8511e84423d029b9bd07969c8d1b331cb765736.tar.bz2
gentoo-e8511e84423d029b9bd07969c8d1b331cb765736.zip
x11-plugins/gkrellweather: Fix dependency on gkrellm[X] and make it work again (#592190 by G.Wolfe Woodbury).
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrellweather/files/gkrellweather-2.0.8-update-locations.patch12
-rw-r--r--x11-plugins/gkrellweather/gkrellweather-2.0.8-r1.ebuild47
2 files changed, 59 insertions, 0 deletions
diff --git a/x11-plugins/gkrellweather/files/gkrellweather-2.0.8-update-locations.patch b/x11-plugins/gkrellweather/files/gkrellweather-2.0.8-update-locations.patch
new file mode 100644
index 000000000000..0faf2627170f
--- /dev/null
+++ b/x11-plugins/gkrellweather/files/gkrellweather-2.0.8-update-locations.patch
@@ -0,0 +1,12 @@
+--- gkrellweather-2.0.8/GrabWeather 2009-01-11 13:15:02.000000000 -0500
++++ gkrellweather-2.0.8-r1/GrabWeather 2016-08-29 00:02:35.345041005 -0400
+@@ -12,7 +12,8 @@
+
+ $ReportDir = '.wmWeatherReports';
+ #$WeatherSrc = 'ftp://weather.noaa.gov/data/observations/metar/decoded';
+-$WeatherSrc = 'http://weather.noaa.gov/pub/data/observations/metar/decoded';
++#$WeatherSrc = 'http://weather.noaa.gov/pub/data/observations/metar/decoded';
++$WeatherSrc = 'http://tgftp.nws.noaa.gov/data/observations/metar/decoded/';
+
+ use strict;
+ use vars qw( $ReportDir $WeatherSrc );
diff --git a/x11-plugins/gkrellweather/gkrellweather-2.0.8-r1.ebuild b/x11-plugins/gkrellweather/gkrellweather-2.0.8-r1.ebuild
new file mode 100644
index 000000000000..90b45a7f13cb
--- /dev/null
+++ b/x11-plugins/gkrellweather/gkrellweather-2.0.8-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="GKrellM2 Plugin that monitors a METAR station and displays weatherinfo"
+HOMEPAGE="https://sites.google.com/site/makovick/gkrellm-plugins"
+SRC_URI="https://sites.google.com/site/makovick/projects/${P}.tgz"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ app-admin/gkrellm[X]
+ >=dev-lang/perl-5.6.1
+ >=net-misc/wget-1.5.3
+"
+DEPEND="
+ >=sys-apps/sed-4.0.5
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-Respect-LDFLAGS.patch
+ "${FILESDIR}"/${P}-Move-GrabWeather.patch
+ "${FILESDIR}"/${P}-update-locations.patch
+)
+
+src_prepare() {
+ default
+ append-cflags $($(tc-getPKG_CONFIG) --cflags gtk+-2.0)
+ append-flags -fPIC
+}
+
+src_compile() {
+ emake PREFIX=/usr CC=$(tc-getCC) CFLAGS="${CFLAGS}"
+}
+
+src_install () {
+ gkrellm-plugin_src_install
+
+ exeinto /usr/libexec/gkrellweather
+ doexe GrabWeather
+}