summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-proto/glproto
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-proto/glproto')
-rw-r--r--x11-proto/glproto/Manifest2
-rw-r--r--x11-proto/glproto/glproto-1.4.16-r1.ebuild41
-rw-r--r--x11-proto/glproto/glproto-1.4.16.ebuild38
-rw-r--r--x11-proto/glproto/glproto-1.4.17-r1.ebuild25
-rw-r--r--x11-proto/glproto/glproto-1.4.17.ebuild41
-rw-r--r--x11-proto/glproto/metadata.xml5
6 files changed, 152 insertions, 0 deletions
diff --git a/x11-proto/glproto/Manifest b/x11-proto/glproto/Manifest
new file mode 100644
index 000000000000..1dcac62fc192
--- /dev/null
+++ b/x11-proto/glproto/Manifest
@@ -0,0 +1,2 @@
+DIST glproto-1.4.16.tar.bz2 119584 SHA256 54dd663a7f5ed702f2ff035b79edf770c2f850867ac0d55742f696bfc8b2598d SHA512 404c72a0f54f31ed639a08b72cbdb6f4d28b76885759df12cdd76fc3ea3b2930c1c8fb7460cd49a36c3a799dc5fd809ffce7da35ff67e1c9604c3c21cca9cb63 WHIRLPOOL 54ce49011b9e4d9a7ab7f0297dec2ab92b707142901fceb2ba60b62db96de16c3b5f9e168c7db24027544dab80d43b9e943c95c89364122486e818c4d34f144c
+DIST glproto-1.4.17.tar.bz2 126969 SHA256 adaa94bded310a2bfcbb9deb4d751d965fcfe6fb3a2f6d242e2df2d6589dbe40 SHA512 3e5bb1949ab9993e07d2ed7e829b9e0a8803eab476e9f4082fc01087c3dce01f3bcb9d55261eaf60e55977a689b326ed1dcf40f74d5e1fc660c83bea094b6754 WHIRLPOOL 48b345a946f136cdd011d25ac796cd43c761fbe052e5d238c6250c4db798c5612978b1e526b10bd1b870bb302f745574a8e4ed8403464305278afb15694f4630
diff --git a/x11-proto/glproto/glproto-1.4.16-r1.ebuild b/x11-proto/glproto/glproto-1.4.16-r1.ebuild
new file mode 100644
index 000000000000..b33c58b656b0
--- /dev/null
+++ b/x11-proto/glproto/glproto-1.4.16-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org GL protocol headers"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+LICENSE="SGI-B-2.0"
+IUSE=""
+
+RDEPEND=">=app-eselect/eselect-opengl-1.2.6"
+DEPEND=""
+
+src_install() {
+ xorg-2_src_install
+ dynamic_libgl_install
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ eselect opengl set --ignore-missing --use-old xorg-x11
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving GL files for dynamic switching"
+ local gldir=/usr/$(get_libdir)/opengl/xorg-x11/include/GL
+ dodir ${gldir}
+ local x=""
+ # glext.h added for #54984
+ for x in "${ED}"/usr/include/GL/{glxtokens.h,glxmd.h,glxproto.h}; do
+ if [[ -f ${x} || -L ${x} ]]; then
+ mv -f "${x}" "${ED}"${gldir}
+ fi
+ done
+ eend 0
+}
diff --git a/x11-proto/glproto/glproto-1.4.16.ebuild b/x11-proto/glproto/glproto-1.4.16.ebuild
new file mode 100644
index 000000000000..5c54fc6a7d2a
--- /dev/null
+++ b/x11-proto/glproto/glproto-1.4.16.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit xorg-2
+DESCRIPTION="X.Org GL protocol headers"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+LICENSE="SGI-B-2.0"
+IUSE=""
+
+RDEPEND=">=app-eselect/eselect-opengl-1.2.6"
+DEPEND=""
+
+src_install() {
+ xorg-2_src_install
+ dynamic_libgl_install
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ eselect opengl set --ignore-missing --use-old xorg-x11
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving GL files for dynamic switching"
+ local gldir=/usr/$(get_libdir)/opengl/xorg-x11/include/GL
+ dodir ${gldir}
+ local x=""
+ # glext.h added for #54984
+ for x in "${ED}"/usr/include/GL/{glxtokens.h,glxmd.h,glxproto.h}; do
+ if [[ -f ${x} || -L ${x} ]]; then
+ mv -f "${x}" "${ED}"${gldir}
+ fi
+ done
+ eend 0
+}
diff --git a/x11-proto/glproto/glproto-1.4.17-r1.ebuild b/x11-proto/glproto/glproto-1.4.17-r1.ebuild
new file mode 100644
index 000000000000..47be112ff005
--- /dev/null
+++ b/x11-proto/glproto/glproto-1.4.17-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org GL protocol headers"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+LICENSE="SGI-B-2.0"
+IUSE=""
+
+RDEPEND=">=app-eselect/eselect-opengl-1.3.0"
+DEPEND=""
+
+src_install() {
+ xorg-2_src_install
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ eselect opengl set --ignore-missing --use-old xorg-x11
+}
diff --git a/x11-proto/glproto/glproto-1.4.17.ebuild b/x11-proto/glproto/glproto-1.4.17.ebuild
new file mode 100644
index 000000000000..945f3eb7f40c
--- /dev/null
+++ b/x11-proto/glproto/glproto-1.4.17.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org GL protocol headers"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+LICENSE="SGI-B-2.0"
+IUSE=""
+
+RDEPEND=">=app-eselect/eselect-opengl-1.2.6"
+DEPEND=""
+
+src_install() {
+ xorg-2_src_install
+ dynamic_libgl_install
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ eselect opengl set --ignore-missing --use-old xorg-x11
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving GL files for dynamic switching"
+ local gldir=/usr/$(get_libdir)/opengl/xorg-x11/include/GL
+ dodir ${gldir}
+ local x=""
+ # glext.h added for #54984
+ for x in "${ED}"/usr/include/GL/{glxtokens.h,glxmd.h,glxproto.h}; do
+ if [[ -f ${x} || -L ${x} ]]; then
+ mv -f "${x}" "${ED}"${gldir}
+ fi
+ done
+ eend 0
+}
diff --git a/x11-proto/glproto/metadata.xml b/x11-proto/glproto/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/x11-proto/glproto/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>