summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-terms/aterm/aterm-1.0.1-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-terms/aterm/aterm-1.0.1-r2.ebuild')
-rw-r--r--x11-terms/aterm/aterm-1.0.1-r2.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/x11-terms/aterm/aterm-1.0.1-r2.ebuild b/x11-terms/aterm/aterm-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..d272af9ee56c
--- /dev/null
+++ b/x11-terms/aterm/aterm-1.0.1-r2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit flag-o-matic eutils
+
+DESCRIPTION="A terminal emulator with transparency support as well as rxvt backwards compatibility"
+HOMEPAGE="http://aterm.sourceforge.net"
+SRC_URI="ftp://ftp.afterstep.org/apps/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="background cjk xgetdefault"
+
+RDEPEND="virtual/jpeg
+ media-libs/libpng
+ background? ( x11-wm/afterstep )
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libICE"
+
+DEPEND="${RDEPEND}
+ x11-libs/libXt
+ x11-proto/xproto"
+
+src_prepare() {
+ # Security bug #219746
+ epatch "${FILESDIR}/${P}-display-security-issue.patch"
+ epatch "${FILESDIR}"/${P}-deadkeys.patch
+
+ #fix pre-stripped files
+ sed -i -e "/INSTALL_PROGRAM/ s:-s::" autoconf/Make.common.in || die "sed Makefile
+ failed"
+}
+
+src_configure() {
+ local myconf
+
+ use cjk && myconf="$myconf
+ --enable-kanji
+ --enable-thai
+ --enable-big5"
+
+ case "${CHOST}" in
+ *-darwin*) myconf="${myconf} --enable-wtmp" ;;
+ *-interix*) ;;
+ *) myconf="${myconf} --enable-utmp --enable-wtmp"
+ esac
+
+ econf \
+ $(use_enable xgetdefault) \
+ $(use_enable background background-image) \
+ --with-terminfo="${EPREFIX}"/usr/share/terminfo \
+ --enable-transparency \
+ --enable-fading \
+ --enable-background-image \
+ --enable-menubar \
+ --enable-graphics \
+ --with-x \
+ ${myconf}
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ fowners root:utmp /usr/bin/aterm
+ fperms g+s /usr/bin/aterm
+
+ doman doc/aterm.1
+ dodoc ChangeLog doc/FAQ doc/README.*
+ docinto menu
+ dodoc doc/menu/*
+ dohtml -r .
+}
+
+pkg_postinst() {
+ echo
+ ewarn "The transparent background will only work if you have the 'real'"
+ ewarn "root wallpaper set. Some tools that might help include: Esetroot"
+ ewarn "(x11-terms/eterm), wmsetbg (x11-wm/windowmaker), and/or"
+ ewarn "media-gfx/feh."
+ echo
+}