summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-10-13 19:47:15 +0200
committerJeroen Roovers <jer@gentoo.org>2017-10-13 19:47:15 +0200
commit15c492816e7828923e1df0eb1dcf8f8fc3a804cd (patch)
treee133237bb9a748868bc84c6d111e489087426f04 /x11-terms/guake/guake-0.8.11.ebuild
parentdev-perl/Geo-IP: Version bump. (diff)
downloadgentoo-15c492816e7828923e1df0eb1dcf8f8fc3a804cd.tar.gz
gentoo-15c492816e7828923e1df0eb1dcf8f8fc3a804cd.tar.bz2
gentoo-15c492816e7828923e1df0eb1dcf8f8fc3a804cd.zip
x11-terms/guake: Version bump.
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'x11-terms/guake/guake-0.8.11.ebuild')
-rw-r--r--x11-terms/guake/guake-0.8.11.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/x11-terms/guake/guake-0.8.11.ebuild b/x11-terms/guake/guake-0.8.11.ebuild
new file mode 100644
index 000000000000..2a8e13d38000
--- /dev/null
+++ b/x11-terms/guake/guake-0.8.11.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GNOME2_LA_PUNT=yes
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils gnome2 python-single-r1
+
+DESCRIPTION="Drop-down terminal for GTK+ desktops"
+HOMEPAGE="https://github.com/Guake/guake"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/keybinder:0[python,${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/gconf-python[${PYTHON_USEDEP}]
+ dev-python/notify-python[${PYTHON_USEDEP}]
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/vte:0[python]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README.rst )
+
+src_prepare() {
+ eapply_user
+
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}