summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-10-17 16:48:36 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-10-17 17:04:38 +0300
commitf8f771366d77a5da014519a5e7c18abc67671520 (patch)
treef0f4dba63f44bf49edf72269b8aaf3d89b94622b /x11-terms/kitty-terminfo/files
parentx11-terms/kitty-terminfo: bump to 0.19.1 (diff)
downloadgentoo-f8f771366d77a5da014519a5e7c18abc67671520.tar.gz
gentoo-f8f771366d77a5da014519a5e7c18abc67671520.tar.bz2
gentoo-f8f771366d77a5da014519a5e7c18abc67671520.zip
x11-terms/kitty: remove old
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms/kitty-terminfo/files')
-rw-r--r--x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.17.2.patch44
-rw-r--r--x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.18.3.patch46
2 files changed, 0 insertions, 90 deletions
diff --git a/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.17.2.patch b/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.17.2.patch
deleted file mode 100644
index 31aa669e0a5e..000000000000
--- a/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.17.2.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/setup.py 2020-03-12 00:28:46.725956882 +0100
-+++ b/setup.py 2020-03-12 00:38:55.557945979 +0100
-@@ -876,6 +876,14 @@
- create_macos_bundle_gunk(ddir)
- # }}}
-
-+def terminfo(args):
-+ ddir = args.prefix
-+ libdir = os.path.join(ddir, args.libdir_name.strip('/'), 'kitty')
-+ build_terminfo = runpy.run_path('build-terminfo', run_name='import_build')
-+ for x in (libdir, os.path.join(ddir, 'share')):
-+ odir = os.path.join(x, 'terminfo')
-+ safe_makedirs(odir)
-+ build_terminfo['compile_terminfo'](odir)
-
- def clean():
-
-@@ -889,7 +897,7 @@
-
- safe_remove(
- 'build', 'compile_commands.json', 'link_commands.json',
-- 'linux-package', 'kitty.app', 'asan-launcher',
-+ 'linux-package', 'linux-terminfo', 'kitty.app', 'asan-launcher',
- 'kitty-profile', 'kitty/launcher')
- exclude = ('.git',)
- for root, dirs, files in os.walk('.', topdown=True):
-@@ -910,7 +918,7 @@
- 'action',
- nargs='?',
- default=Options.action,
-- choices='build test linux-package kitty.app linux-freeze macos-freeze clean'.split(),
-+ choices='build test linux-package linux-terminfo kitty.app linux-freeze macos-freeze clean'.split(),
- help='Action to perform (default is build)'
- )
- p.add_argument(
-@@ -1007,6 +1015,8 @@
- elif args.action == 'linux-package':
- build(args, native_optimizations=False)
- package(args, bundle_type='linux-package')
-+ elif args.action == 'linux-terminfo':
-+ terminfo(args)
- elif args.action == 'linux-freeze':
- build(args, native_optimizations=False)
- package(args, bundle_type='linux-freeze')
diff --git a/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.18.3.patch b/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.18.3.patch
deleted file mode 100644
index ae6f087069c7..000000000000
--- a/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.18.3.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 7c4295bd..8d31e2d1 100755
---- a/setup.py
-+++ b/setup.py
-@@ -856,6 +856,14 @@ Categories=System;TerminalEmulator;
- os.makedirs(os.path.dirname(in_src_launcher), exist_ok=True)
- os.symlink(os.path.relpath(launcher, os.path.dirname(in_src_launcher)), in_src_launcher)
-
-+def terminfo(args):
-+ ddir = args.prefix
-+ libdir = os.path.join(ddir, args.libdir_name.strip('/'), 'kitty')
-+ build_terminfo = runpy.run_path('build-terminfo', run_name='import_build')
-+ for x in (libdir, os.path.join(ddir, 'share')):
-+ odir = os.path.join(x, 'terminfo')
-+ safe_makedirs(odir)
-+ build_terminfo['compile_terminfo'](odir)
-
- def macos_info_plist() -> bytes:
- import plistlib
-@@ -1022,7 +1030,7 @@ def clean() -> None:
-
- safe_remove(
- 'build', 'compile_commands.json', 'link_commands.json',
-- 'linux-package', 'kitty.app', 'asan-launcher',
-+ 'linux-package', 'linux-terminfo', 'kitty.app', 'asan-launcher',
- 'kitty-profile', 'kitty/launcher')
- exclude = ('.git',)
- for root, dirs, files in os.walk('.', topdown=True):
-@@ -1045,7 +1053,7 @@ def option_parser() -> argparse.ArgumentParser: # {{{
- 'action',
- nargs='?',
- default=Options.action,
-- choices='build test linux-package kitty.app linux-freeze macos-freeze build-launcher clean'.split(),
-+ choices='build test linux-package linux-terminfo kitty.app linux-freeze macos-freeze build-launcher clean'.split(),
- help='Action to perform (default is build)'
- )
- p.add_argument(
-@@ -1166,6 +1174,8 @@ def main() -> None:
- elif args.action == 'linux-package':
- build(args, native_optimizations=False)
- package(args, bundle_type='linux-package')
-+ elif args.action == 'linux-terminfo':
-+ terminfo(args)
- elif args.action == 'linux-freeze':
- build(args, native_optimizations=False)
- package(args, bundle_type='linux-freeze')