summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-11-18 14:52:34 -0700
committerTim Harder <radhermit@gentoo.org>2019-11-18 14:56:04 -0700
commitd96787fd9d20aaa1d2e0ccba8ce804a712587297 (patch)
tree78a3fd9bb9342e4d4916ed82363a4a74b30e22d5 /x11-terms/kitty/kitty-9999.ebuild
parentx11-misc/unclutter-xfixes: drop myself as a maintainer (diff)
downloadgentoo-d96787fd9d20aaa1d2e0ccba8ce804a712587297.tar.gz
gentoo-d96787fd9d20aaa1d2e0ccba8ce804a712587297.tar.bz2
gentoo-d96787fd9d20aaa1d2e0ccba8ce804a712587297.zip
x11-terms/kitty: update to EAPI 7 and fix BDEPEND
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'x11-terms/kitty/kitty-9999.ebuild')
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index c51e3ffd52d4..1d1a09c24c6b 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
-inherit python-single-r1 toolchain-funcs gnome2-utils
+inherit python-single-r1 toolchain-funcs xdg
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
@@ -49,9 +49,9 @@ RDEPEND="
DEPEND="${RDEPEND}
media-libs/mesa[X(+)]
sys-libs/ncurses
- virtual/pkgconfig
"
[[ ${PV} == *9999 ]] && DEPEND+=" >=dev-python/sphinx-1.7[${PYTHON_USEDEP}]"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-flags.patch
@@ -90,8 +90,8 @@ src_test() {
}
src_install() {
- mkdir -p "${ED}"usr || die
- cp -r linux-package/* "${ED}usr" || die
+ mkdir -p "${ED}"/usr || die
+ cp -r linux-package/* "${ED}/usr" || die
python_fix_shebang "${ED}"
if ! use doc; then
@@ -100,9 +100,9 @@ src_install() {
}
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}