summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-05-26 00:42:06 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-05-26 02:06:02 -0400
commit26ee634bb6a50e6c58ef4ab53635fa7d986620d0 (patch)
tree17b5a3f786f414a223983ba3e4209f8e5b406d9f /x11-terms/kitty
parentx11-terms/kitty-terminfo: add 0.25.1 (diff)
downloadgentoo-26ee634bb6a50e6c58ef4ab53635fa7d986620d0.tar.gz
gentoo-26ee634bb6a50e6c58ef4ab53635fa7d986620d0.tar.bz2
gentoo-26ee634bb6a50e6c58ef4ab53635fa7d986620d0.zip
x11-terms/kitty: add 0.25.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms/kitty')
-rw-r--r--x11-terms/kitty/Manifest2
-rw-r--r--x11-terms/kitty/kitty-0.25.1.ebuild134
2 files changed, 136 insertions, 0 deletions
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index af4e25042283..1234292c6114 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -1,2 +1,4 @@
DIST kitty-0.25.0.tar.xz 4640360 BLAKE2B 2f982ecb2d13c49a6971d4a863f2215f22ccae2cc50fd7b6c6b5c2facf781ac23ec627edcbec8ebaa538c5d67b0b62ad4cc05aedf90fd722d9d886c2f62d5b42 SHA512 fed8d66a9f7f2117f4b495305db0d56d8b85ef03bf7ef24a7dca31e63e16fc90e026aa8022237ad45678efb026f11fdd8aa377eb53917fd8ec885f2ccea721f8
DIST kitty-0.25.0.tar.xz.sig 566 BLAKE2B 94d082c4520d1a25c9ea104df94876e342cc84fcc049ebc0b6061fe71206e98c5b5f8aa841ed636988b33f72f122b2d84f39e10d319c1d56c9cbf37d1b6fc064 SHA512 827546ea38af4babf431031184203bd11853469f87826a6b86f45b0b7d087e7523eee935908ca5a5e4a7a87e01d75114ed348ff39a9a0f6329d372fac15841af
+DIST kitty-0.25.1.tar.xz 4671008 BLAKE2B f5110c64e3659499351875dfb4ad9dba85724184cbb742d4b2fe63dcb604b5c8e8736c51ae126345736cbb90238ba3c9e3de099cd6ebfdd0e50b5dfb36c2d2b6 SHA512 6d9862f8411372e0cf692114d6e29eb92db3a2e324282a21ca35b2ca5229c9d87ab988e802e44d47e98b6e64ae7abc5ff0cc677c082eb287e14ee68cd1a4c31e
+DIST kitty-0.25.1.tar.xz.sig 566 BLAKE2B 7fba36cd7c5d06274e21106e2f31ecb0c22362a2798eeebc3f8a8935609d4f8fe0a39b059ea13a4fe4fcb54b7632416508040244b6beaa1b525c9de926c72959 SHA512 d3b3b764191e44c9e1e1d46a4868915986f871338c414e7f135e99a158be08c68819e8823cf64c3c7414bec58f39146387c3372cea30568faabdcab05917fc26
diff --git a/x11-terms/kitty/kitty-0.25.1.ebuild b/x11-terms/kitty/kitty-0.25.1.ebuild
new file mode 100644
index 000000000000..531d4fb7df94
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.25.1.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit optfeature multiprocessing python-single-r1 toolchain-funcs xdg
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+else
+ inherit verify-sig
+ SRC_URI="
+ https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz
+ verify-sig? ( https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz.sig )"
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/kovidgoyal.gpg"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Fast, feature-rich, GPU-based terminal"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+X debug test transfer wayland"
+REQUIRED_USE="
+ || ( X wayland )
+ ${PYTHON_REQUIRED_USE}"
+RESTRICT="!X? ( test ) !test? ( test ) !transfer? ( test ) !wayland? ( test )"
+
+# dlopen: fontconfig,libglvnd
+RDEPEND="
+ ${PYTHON_DEPS}
+ media-libs/fontconfig
+ media-libs/harfbuzz:=
+ media-libs/lcms:2
+ media-libs/libglvnd[X?]
+ media-libs/libpng:=
+ sys-apps/dbus
+ sys-libs/zlib:=
+ x11-libs/libxkbcommon[X?]
+ x11-misc/xkeyboard-config
+ ~x11-terms/kitty-shell-integration-${PV}
+ ~x11-terms/kitty-terminfo-${PV}
+ X? ( x11-libs/libX11 )
+ transfer? ( net-libs/librsync:= )
+ wayland? ( dev-libs/wayland )"
+DEPEND="
+ ${RDEPEND}
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libXcursor
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ )
+ wayland? ( dev-libs/wayland-protocols )"
+BDEPEND="
+ ${PYTHON_DEPS}
+ sys-libs/ncurses
+ virtual/pkgconfig
+ test? ( $(python_gen_cond_dep 'dev-python/pillow[${PYTHON_USEDEP}]') )
+ wayland? ( dev-util/wayland-scanner )"
+[[ ${PV} == 9999 ]] || BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.23.1-flags.patch
+)
+
+src_prepare() {
+ default
+
+ sed -e "s/'x11 wayland'/'$(usev X x11) $(usev wayland)'/" \
+ -e "/num_workers = /s/=.*/= $(makeopts_jobs)/" \
+ -i setup.py || die
+
+ if use !transfer; then
+ sed -i 's/rs_cflag =/& []#/;/files.*rsync/d' setup.py || die
+ rm -r kittens/transfer || die
+ fi
+
+ # test relies on 'who' command which doesn't detect users with pid-sandbox
+ rm kitty_tests/utmp.py || die
+
+ # test may fail/hang depending on environment and shell initialization scripts
+ rm kitty_tests/{shell_integration,ssh}.py || die
+
+ # skip docs for live version
+ [[ ${PV} != 9999 ]] || sed -i '/exists.*_build/,/docs(ddir)/d' setup.py || die
+}
+
+src_compile() {
+ tc-export CC
+ export PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+
+ local setup=(
+ ${EPYTHON} setup.py linux-package
+ --disable-link-time-optimization
+ --ignore-compiler-warnings
+ --libdir-name=$(get_libdir)
+ --shell-integration="enabled no-rc"
+ --update-check-interval=0
+ --verbose
+ $(usev debug --debug)
+ )
+
+ echo "${setup[*]}"
+ "${setup[@]}" || die "setup.py failed to compile ${PN}"
+
+ [[ ${PV} == 9999 ]] || mv linux-package/share/doc/{${PN},${PF}} || die
+ rm -r linux-package/share/terminfo || die
+}
+
+src_test() {
+ PATH=linux-package/bin:${PATH} KITTY_CONFIG_DIRECTORY=${T} \
+ ${EPYTHON} test.py || die
+}
+
+src_install() {
+ insinto /usr
+ doins -r linux-package/.
+
+ fperms +x /usr/bin/kitty \
+ /usr/$(get_libdir)/kitty/shell-integration/ssh/{askpass.py,kitty}
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "in-terminal image display with kitty icat" media-gfx/imagemagick
+ optfeature "audio-based terminal bell support" media-libs/libcanberra
+ optfeature "opening links from the terminal" x11-misc/xdg-utils
+}