summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorend222 <pabloorduna98@gmail.com>2021-07-01 23:03:46 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-07-14 09:25:19 +0300
commit50476b6bfc29ac4ccb5ac6ee3806b17ae5c2f5e7 (patch)
tree856b32a521b5936c7ca2feec40e6ed90964af3b6 /x11-terms/kitty
parentnet-dns/knot: bump to 3.0.7 (diff)
downloadgentoo-50476b6bfc29ac4ccb5ac6ee3806b17ae5c2f5e7.tar.gz
gentoo-50476b6bfc29ac4ccb5ac6ee3806b17ae5c2f5e7.tar.bz2
gentoo-50476b6bfc29ac4ccb5ac6ee3806b17ae5c2f5e7.zip
x11-terms/kitty: bump to 0.21.2
Signed-off-by: Pablo Orduna <pabloorduna98@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms/kitty')
-rw-r--r--x11-terms/kitty/Manifest1
-rw-r--r--x11-terms/kitty/files/kitty-0.21.2-flags.patch (renamed from x11-terms/kitty/files/kitty-9999-flags.patch)0
-rw-r--r--x11-terms/kitty/files/kitty-0.21.2-remove-terminfo.patch (renamed from x11-terms/kitty/files/kitty-9999-remove-terminfo.patch)0
-rw-r--r--x11-terms/kitty/kitty-0.21.2.ebuild109
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild4
5 files changed, 112 insertions, 2 deletions
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index 8a8bf738a61a..e1a1774bb2ae 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -1,3 +1,4 @@
DIST kitty-0.19.3.tar.xz 3269628 BLAKE2B b3b673f8ad06baf770b03bcee87b2f405e1ff09d0fa5c6a232fd8df651351a428c8fbd9e2d0dc90ed44a0d6632192bea83650388ee73ebc3b523f51e51168006 SHA512 d1eea7f909c9492542650a83a149fd279c44380cf10387759f10caad57cd4dbabeac1ce84e8142bfa47266ec2562dfa3766ce08e2aee4d8e0ebacea165f101e4
DIST kitty-0.20.1.tar.xz 3449932 BLAKE2B aed9a250fbc7005cd67fd22bfc33de845bea7e39a5561e6957b744f03a5438945f9739ca7066a93889144a5d0289185f337ef4d487c754cba37f242030f1c46a SHA512 19dfa66eb2a2115877b25fbff0ba7a81071bff00c732236f20342aeb619cca88ae4a4e8ce4e73908ac7d7d12fca5232a76e0167754f2e658af02e442cf5ba0cd
DIST kitty-0.20.3.tar.xz 3487500 BLAKE2B 49397ac2aef10e5fc41e351af65050ad510e58915392e6b1b8c022db31f2e5e81ac2cce645468ff213dafb609a30d43934b7388b93227fbbba5af7aa35be74e8 SHA512 9e9d81696bcb0d3894c04b08bc52ccf7aaf533125b3ecfb4c894b8d42dbf8511239c49f1c977d81872ce49fc6b3aa8e8c92b9c944bd31fe59fce6e3750295e58
+DIST kitty-0.21.2.tar.xz 4341440 BLAKE2B dd97d65ae6eb39b5676cc809d3b5ca48b0fcbbb4bb9cc1d212efeb1b5fb584f61decca9d286fdee6f4512aa4d56e08b3a19be70afa2f0155c8c1815e29fcd7ed SHA512 0ae41dfd61fc70746e8ec2d37c043dea7ceb70205aca056fd156348d4b9a2f6aac520c60de08fb5a3cd9bb908efdd2ad8129bbc01b69e5908f2976e5393269df
diff --git a/x11-terms/kitty/files/kitty-9999-flags.patch b/x11-terms/kitty/files/kitty-0.21.2-flags.patch
index 0e773c677650..0e773c677650 100644
--- a/x11-terms/kitty/files/kitty-9999-flags.patch
+++ b/x11-terms/kitty/files/kitty-0.21.2-flags.patch
diff --git a/x11-terms/kitty/files/kitty-9999-remove-terminfo.patch b/x11-terms/kitty/files/kitty-0.21.2-remove-terminfo.patch
index 39fe84b3b2a0..39fe84b3b2a0 100644
--- a/x11-terms/kitty/files/kitty-9999-remove-terminfo.patch
+++ b/x11-terms/kitty/files/kitty-0.21.2-remove-terminfo.patch
diff --git a/x11-terms/kitty/kitty-0.21.2.ebuild b/x11-terms/kitty/kitty-0.21.2.ebuild
new file mode 100644
index 000000000000..d08fd64a821e
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.21.2.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit optfeature python-single-r1 toolchain-funcs xdg
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A modern, hackable, featureful, OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug wayland"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ media-libs/fontconfig
+ media-libs/freetype:2
+ >=media-libs/harfbuzz-1.5.0:=
+ media-libs/lcms
+ media-libs/libcanberra
+ media-libs/libpng:0=
+ sys-apps/dbus
+ sys-libs/zlib
+ x11-libs/libxcb[xkb]
+ x11-libs/libXcursor
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libxkbcommon[X]
+ x11-libs/libXrandr
+ x11-terms/kitty-terminfo
+ wayland? (
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.17
+ )
+"
+
+DEPEND="${RDEPEND}
+ media-libs/mesa[X]
+ sys-libs/ncurses
+"
+
+BDEPEND="virtual/pkgconfig"
+
+[[ ${PV} == *9999 ]] && BDEPEND+=" >=dev-python/sphinx-1.7"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.21.2-flags.patch
+ "${FILESDIR}"/${PN}-0.14.4-svg-icon.patch
+ "${FILESDIR}"/${PN}-0.21.2-remove-terminfo.patch
+ "${FILESDIR}"/${PN}-0.20.1-tests.patch
+)
+
+src_prepare() {
+ default
+
+ # disable wayland as required
+ if ! use wayland; then
+ sed -i "/'x11 wayland'/s/ wayland//" setup.py || die
+ # also disable wayland tests
+ sed -i "/if not self.is_ci/d" kitty_tests/check_build.py || die
+ sed -i "/linux_backends.append('wayland')/d" kitty_tests/check_build.py || die
+ fi
+
+ # respect doc dir
+ sed -i "/htmldir =/s/appname/'${PF}'/" setup.py || die
+
+ tc-export CC
+}
+
+src_compile() {
+ "${EPYTHON}" setup.py \
+ --verbose $(usex debug --debug "") \
+ --libdir-name $(get_libdir) \
+ --update-check-interval=0 \
+ linux-package || die "Failed to compile kitty."
+}
+
+src_test() {
+ export KITTY_CONFIG_DIRECTORY=${T}
+ "${EPYTHON}" test.py || die
+}
+
+src_install() {
+ insinto /usr
+ doins -r linux-package/*
+ dobin linux-package/bin/kitty
+ python_fix_shebang "${ED}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ optfeature "Displaying images in the terminal" virtual/imagemagick-tools
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index e67ade738230..eee99356183e 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -57,8 +57,8 @@ BDEPEND="virtual/pkgconfig"
$(python_gen_cond_dep '>=dev-python/sphinx-1.7[${PYTHON_MULTI_USEDEP}]')"
PATCHES=(
- "${FILESDIR}"/${P}-flags.patch
- "${FILESDIR}"/${P}-remove-terminfo.patch
+ "${FILESDIR}"/${PN}-0.21.2-flags.patch
+ "${FILESDIR}"/${PN}-0.21.2-remove-terminfo.patch
"${FILESDIR}"/${PN}-0.14.4-svg-icon.patch
)