summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-02-26 14:55:43 -0500
committerTim Harder <radhermit@gentoo.org>2018-03-01 14:34:47 -0500
commit78fbf2651744c9236defdc60b6f7861cae4bf3fe (patch)
tree699b31686169b810813270c4e26026d2f4645336 /x11-terms/kitty
parentsys-apps/ripgrep: remove old (diff)
downloadgentoo-78fbf2651744c9236defdc60b6f7861cae4bf3fe.tar.gz
gentoo-78fbf2651744c9236defdc60b6f7861cae4bf3fe.tar.bz2
gentoo-78fbf2651744c9236defdc60b6f7861cae4bf3fe.zip
x11-terms/kitty: version bump to 0.8.0
Diffstat (limited to 'x11-terms/kitty')
-rw-r--r--x11-terms/kitty/Manifest1
-rw-r--r--x11-terms/kitty/kitty-0.8.0.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index d6aa26784302..aba578c49bba 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -1 +1,2 @@
DIST kitty-0.7.1.tar.gz 2535007 BLAKE2B 13c5506b30e54b190d1cec2c2bb5b3b8c76ba3492a065fccae84c84606842b717dc33f74a7b3abf4c0ffec8564c5dd9be4b6ed3972c24cf95662aec594359bc9 SHA512 595e64e49ac940b37ff88d6152006ebfe2722682a8ff6c8bc2514c150a5b51934b9de5b8c99130910e5638f9c1db566abf4adb65f3fdce893708787d1ded59c1
+DIST kitty-0.8.0.tar.gz 3265837 BLAKE2B 2bd623a1f7024e3d6fe11132516a5c165d890faaa80cf2bc23f0a35852c331eede1fbeb0ab0e3588da6d41e7700d8643cd82bbb45bee4c8f359ff4b9f00fb081 SHA512 909faf13bd27c03eed463400d157f453363142fd31b4aaf49be37ed85bcd417077667fc02a8c78c6dccf4c1d326cfe3cff4996f591e16eda8335cf165abb42fd
diff --git a/x11-terms/kitty/kitty-0.8.0.ebuild b/x11-terms/kitty/kitty-0.8.0.ebuild
new file mode 100644
index 000000000000..e92bab9de3b4
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.8.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit python-single-r1 toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/kovidgoyal/kitty/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A modern, hackable, featureful, OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug imagemagick wayland"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPS="
+ ${PYTHON_DEPS}
+ >=media-libs/harfbuzz-1.5.0:=
+ sys-libs/zlib
+ media-libs/libpng:0=
+ media-libs/freetype:2
+ media-libs/fontconfig
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXinerama
+ x11-libs/libxkbcommon[X]
+ wayland? (
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.12
+ )
+"
+RDEPEND="
+ ${COMMON_DEPS}
+ imagemagick? ( virtual/imagemagick-tools )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.1-flags.patch
+ "${FILESDIR}"/${PN}-0.7.1-svg-icon.patch
+)
+
+src_prepare() {
+ default
+
+ # respect libdir
+ sed -i "/libdir =/s/'lib'/'$(get_libdir)'/" setup.py || die
+ sed -i "s#/../lib/kitty#/../$(get_libdir)/kitty#" linux-launcher.c || die
+
+ # disable wayland as required
+ if ! use wayland; then
+ sed -i "/'x11 wayland'/s/ wayland//" setup.py || die
+ fi
+
+ tc-export CC
+}
+
+doecho() {
+ echo "$@"
+ "$@" || die
+}
+
+src_compile() {
+ doecho "${EPYTHON}" setup.py --verbose $(usex debug --debug "") linux-package
+}
+
+src_test() {
+ export KITTY_CONFIG_DIRECTORY=${T}
+ "${EPYTHON}" test.py || die
+}
+
+src_install() {
+ mkdir -p "${ED}"usr || die
+ cp -r linux-package/* "${ED}usr" || die
+ python_fix_shebang "${ED}"
+
+ dodoc CHANGELOG.rst *.asciidoc
+}