summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-19 02:43:04 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-19 02:48:49 -0400
commitb494c8bcbfd646358281be78769ff2a4d08684cf (patch)
tree1428940e05456bfec0de81b4faaf6c9e89e83fa0 /x11-terms/kitty
parentx11-terms/kitty-terminfo: add 0.34.1 (diff)
downloadgentoo-b494c8bcbfd646358281be78769ff2a4d08684cf.tar.gz
gentoo-b494c8bcbfd646358281be78769ff2a4d08684cf.tar.bz2
gentoo-b494c8bcbfd646358281be78769ff2a4d08684cf.zip
x11-terms/kitty: add 0.34.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms/kitty')
-rw-r--r--x11-terms/kitty/Manifest3
-rw-r--r--x11-terms/kitty/kitty-0.34.1.ebuild190
2 files changed, 193 insertions, 0 deletions
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index 5f99c90773fa..06819e644b1d 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -7,3 +7,6 @@ DIST kitty-0.33.1.tar.xz.sig 566 BLAKE2B 568d54993d6c66670279364c317fa0778594852
DIST kitty-0.34.0-vendor.tar.xz 1528164 BLAKE2B e3e97d818f9de422cbfd72491b3aadccf21702b408933c4c2db03ba8cea30bd28bd472b296e5504179fc3f756ff5c3f041511da410b41c9b52904ecd5c7b6fa6 SHA512 ffd92f673e3552f773513d04987d73d0b0cd7beec3685614e0c506675b6ab0eb400bba5e7c6904e57b03a13c8e09492bec655f154f052de504e26e7c2b458e5b
DIST kitty-0.34.0.tar.xz 8227440 BLAKE2B 8e5b27d095a73711995f5f9c7b320e13632893ae3040204d643e5fe29a98c0337aff3abd4aa91300c84fa8fc435a077beddbbec123937b6db29a2c2f3fb1e89c SHA512 310084af59fb5832c9b87961d278601a8408fdcf4500083ffa5d4980ae600a2122a7477be23bfe0c374dec7955707894cb74cfd550ae577d66e39ed2e8b9c0f8
DIST kitty-0.34.0.tar.xz.sig 566 BLAKE2B 83fb2de657c26d9cc7718d9d08c81d175419598223c16185243851c0308404b7139a6da2ec2c5c0a24294ebd1f242f4cc1c905a355f59422a299c3893d2235ef SHA512 04283095f3c778379b3f26d94863f50a6c965a59d84431c21fabfeeb3d768cd427c6e1ded56684aa4d56e2fd441b2cbaebb3b2e0f328e2f30ca97b70076b37cb
+DIST kitty-0.34.1-vendor.tar.xz 1528400 BLAKE2B fde7ba3a9713e10e1b6f3d4e3a35bb1edf0ed50004862e2f367df30b416a1b8e34c03c38c47ec4f7363bc10eace0dd03215875c1b5121151671c0b22ac47e189 SHA512 875ca8c324b80e3be8fead1c56710f7f9ca7f5aa0f8e4e8f1e825005cbe85837d9b58a2b271ead201637f9b10fd5e61b7e8e52276e950f30fe326546c6ee33ee
+DIST kitty-0.34.1.tar.xz 8176176 BLAKE2B c39709a065a04b04bf15e6decb9a96c1699c1082de44690c36e4e05a288f6835fa3c5dd059c363a272c98934b5c66cf5d79078b6403c7f15a9e94f3f72aa680c SHA512 1b361823741c8c2a6ce3c5d56d0cbbd51bd0a0d2574312ef5c05f359c70862e0889a9636e4b95865750cbd239b517763315ed0cf4ec46e1feaffc27cf20e0e66
+DIST kitty-0.34.1.tar.xz.sig 566 BLAKE2B fb01069e33f958bfc1aee3e42ab5d8d775d79cf0c54b427690f4455c524d9baff3789823a6a8dce6494a8006715bc17530f1569c540b30f423c41f8833ae08f8 SHA512 cf60f1044661a62e73191526680ce862ae02e0dd89e017c139261cff8667b20be6aca0fb3b56f06c8ddb0e08a3c55eb428358a9db0b59ef65f2bd246fcf9cd01
diff --git a/x11-terms/kitty/kitty-0.34.1.ebuild b/x11-terms/kitty/kitty-0.34.1.ebuild
new file mode 100644
index 000000000000..66daa0ec2a6d
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.34.1.ebuild
@@ -0,0 +1,190 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit edo flag-o-matic go-env optfeature multiprocessing
+inherit python-single-r1 toolchain-funcs xdg
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+else
+ inherit verify-sig
+ SRC_URI="
+ https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~ionen/distfiles/${P}-vendor.tar.xz
+ verify-sig? ( https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz.sig )
+ "
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/kovidgoyal.gpg
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Fast, feature-rich, GPU-based terminal"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+
+LICENSE="GPL-3 ZLIB"
+LICENSE+=" Apache-2.0 BSD BSD-2 MIT MPL-2.0" # go
+SLOT="0"
+IUSE="+X test wayland"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( X wayland )
+ test? ( X wayland )
+"
+RESTRICT="!test? ( test )"
+
+# dlopen: fontconfig,libglvnd
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/openssl:=
+ dev-libs/xxhash
+ media-libs/fontconfig
+ media-libs/harfbuzz:=[truetype]
+ media-libs/lcms:2
+ media-libs/libglvnd[X?]
+ media-libs/libpng:=
+ sys-apps/dbus
+ sys-libs/zlib:=
+ x11-libs/libxkbcommon[X?]
+ x11-misc/xkeyboard-config
+ ~x11-terms/kitty-shell-integration-${PV}
+ ~x11-terms/kitty-terminfo-${PV}
+ X? (
+ x11-libs/libX11
+ x11-libs/libXcursor
+ )
+ wayland? ( dev-libs/wayland )
+ !sci-mathematics/kissat
+"
+DEPEND="
+ ${RDEPEND}
+ amd64? ( >=dev-libs/simde-0.8.0-r1 )
+ arm64? ( dev-libs/simde )
+ x86? ( dev-libs/simde )
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ )
+ wayland? ( dev-libs/wayland-protocols )
+"
+# bug #919751 wrt go subslot
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-lang/go-1.22:=
+ sys-libs/ncurses
+ virtual/pkgconfig
+ test? ( $(python_gen_cond_dep 'dev-python/pillow[${PYTHON_USEDEP}]') )
+ wayland? ( dev-util/wayland-scanner )
+"
+[[ ${PV} == 9999 ]] || BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )"
+
+QA_FLAGS_IGNORED="usr/bin/kitten" # written in Go
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ cd "${S}" || die
+ edo go mod vendor
+ else
+ use verify-sig &&
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ # sed unfortunately feels easier on maintenance than patches here
+ local sedargs=(
+ -e "/num_workers =/s/=.*/= $(makeopts_jobs)/"
+ -e "s/cflags.append.*-O3.*/pass/" -e 's/-O3//'
+ -e "s/cflags.append(fortify_source)/pass/" # use toolchain's _f_s
+ -e "s/ld_flags.append('-[sw]')/pass/"
+ )
+
+ # kitty is often popular on wayland-only setups, try to allow this
+ use !X && sedargs+=( -e '/gl_libs =/s/=.*/= []/' ) #857918
+ use !X || use !wayland &&
+ sedargs+=( -e "s/'x11 wayland'/'$(usex X x11 wayland)'/" )
+
+ # skip docs for live version, missing dependencies
+ [[ ${PV} == 9999 ]] && sedargs+=( -e '/exists.*_build/,/docs(ddir)/d' )
+
+ sed -i setup.py "${sedargs[@]}" || die
+
+ local skiptests=(
+ # relies on 'who' command which doesn't detect users with pid-sandbox
+ kitty_tests/utmp.py
+ # may fail/hang depending on environment and shell initialization
+ kitty_tests/{shell_integration,ssh}.py
+ # relies on /proc/self/fd and gets confused when ran from here
+ tools/utils/tpmfile_test.go
+ )
+ use !test || rm "${skiptests[@]}" || die
+}
+
+src_compile() {
+ tc-export CC
+ local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+
+ go-env_set_compile_environment
+ local -x GOFLAGS="-p=$(makeopts_jobs) -v -x -buildvcs=false"
+ use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
+
+ # workaround link errors with Go + gcc + -g3 (bug #924436),
+ # retry now and then to see if can be dropped
+ tc-is-gcc &&
+ CGO_CFLAGS=$(
+ CFLAGS=${CGO_CFLAGS}
+ replace-flags -g3 -g
+ replace-flags -ggdb3 -ggdb
+ printf %s "${CFLAGS}"
+ )
+
+ local conf=(
+ --disable-link-time-optimization
+ --ignore-compiler-warnings
+ --libdir-name=$(get_libdir)
+ --shell-integration="enabled no-rc no-sudo"
+ --update-check-interval=0
+ --verbose
+ )
+
+ edo "${EPYTHON}" setup.py linux-package "${conf[@]}"
+ use test && edo "${EPYTHON}" setup.py build-launcher "${conf[@]}"
+
+ rm -r linux-package/share/terminfo || die # provided by kitty-terminfo
+
+ if [[ ${PV} == 9999 ]]; then
+ mkdir -p linux-package/share/doc/${PF} || die
+ else
+ mv linux-package/share/doc/{${PN},${PF}} || die
+ fi
+
+ # generate default config as reference, command taken from docs/conf.rst
+ if ! tc-is-cross-compiler; then
+ linux-package/bin/kitty +runpy \
+ 'from kitty.config import *; print(commented_out_default_config())' \
+ > linux-package/share/doc/${PF}/kitty.conf || die
+ fi
+}
+
+src_test() {
+ KITTY_CONFIG_DIRECTORY=${T} ./test.py || die # shebang is kitty
+}
+
+src_install() {
+ edo mv linux-package "${ED}"/usr
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "audio-based terminal bell support" media-libs/libcanberra
+ optfeature "opening links from the terminal" x11-misc/xdg-utils
+}