summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-04-01 15:44:27 -0400
committerTim Harder <radhermit@gentoo.org>2018-04-01 15:49:05 -0400
commitbf2046e918d716478d45f0588fa3d57328a158bd (patch)
tree4bd0dc8b547a7342cc0b3d6f84bfe4d78a28d83c /x11-terms/kitty
parentdev-perl/libintl-perl: Cleanup old re bug #613804 (diff)
downloadgentoo-bf2046e918d716478d45f0588fa3d57328a158bd.tar.gz
gentoo-bf2046e918d716478d45f0588fa3d57328a158bd.tar.bz2
gentoo-bf2046e918d716478d45f0588fa3d57328a158bd.zip
x11-term/kitty: version bump to 0.8.4
Diffstat (limited to 'x11-terms/kitty')
-rw-r--r--x11-terms/kitty/Manifest1
-rw-r--r--x11-terms/kitty/kitty-0.8.4.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index 27a671fd5c64..5cf9235f5672 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -1,2 +1,3 @@
DIST kitty-0.8.2.tar.gz 3281308 BLAKE2B 6219dddc02e8b98b913356708fd2e398ad17aea97b0c539132b2333a736324d76136a6b6599b925424a8e7c578e9ef92b38ef5aa8ea5b42788731ecf19ad5e27 SHA512 4dabbce40a5fe0e54ac64b429baf3491ab492846f0f31b4b763c06c7aeba80a482bfd083419d3ddcd1bc267553458b719df82a2a179d90a88be3ce41a47d9897
DIST kitty-0.8.3.tar.gz 3285120 BLAKE2B dcf47345f26beaaae5a63f122a3592c29a8ef2243406377ebb46fd44b9d8036f2f5493d7b1048195e12a7fb9874fce920ac52a0bb18e071e5e3db869691174d9 SHA512 b758a178b976d7dc133dd48bfafff5db8a373419a67206a8724695392c0654a9d5ba07867cbd6824afe1a5c013724d8472ab4087eae52c8bdb27843688b18968
+DIST kitty-0.8.4.tar.gz 3285125 BLAKE2B ad0e1b94caab2b572baabf8340dad703cf6e572494b938fd6941d053deaee9d628d652af9c542efee6ecc2fe71fd7c534595449cb25e50438276d4d0361a61d9 SHA512 1ed5b909f66abd113d643420fadf4034fe0af5b649c957590f0698c541e26d0d061a5d703b8e6220f4be826b2b9914ecb3559fc644eb41cb7cd4b9465030cd93
diff --git a/x11-terms/kitty/kitty-0.8.4.ebuild b/x11-terms/kitty/kitty-0.8.4.ebuild
new file mode 100644
index 000000000000..b51c9110b0ed
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.8.4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit python-single-r1 toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/kovidgoyal/kitty/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A modern, hackable, featureful, OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug imagemagick wayland"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPS="
+ ${PYTHON_DEPS}
+ >=media-libs/harfbuzz-1.5.0:=
+ sys-libs/zlib
+ media-libs/libpng:0=
+ media-libs/freetype:2
+ media-libs/fontconfig
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libxkbcommon[X]
+ wayland? (
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.12
+ )
+"
+RDEPEND="
+ ${COMMON_DEPS}
+ imagemagick? ( virtual/imagemagick-tools )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.1-flags.patch
+ "${FILESDIR}"/${PN}-0.7.1-svg-icon.patch
+)
+
+src_prepare() {
+ default
+
+ # disable wayland as required
+ if ! use wayland; then
+ sed -i "/'x11 wayland'/s/ wayland//" setup.py || die
+ fi
+
+ tc-export CC
+}
+
+doecho() {
+ echo "$@"
+ "$@" || die
+}
+
+src_compile() {
+ doecho "${EPYTHON}" setup.py --verbose $(usex debug --debug "") --libdir-name $(get_libdir) linux-package
+}
+
+src_test() {
+ export KITTY_CONFIG_DIRECTORY=${T}
+ "${EPYTHON}" test.py || die
+}
+
+src_install() {
+ mkdir -p "${ED}"usr || die
+ cp -r linux-package/* "${ED}usr" || die
+ python_fix_shebang "${ED}"
+
+ dodoc CHANGELOG.rst *.asciidoc
+}