summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-terms/mrxvt/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-terms/mrxvt/files')
-rw-r--r--x11-terms/mrxvt/files/mrxvt-0.5.4-001-fix-segfault-when-wd-empty.patch13
-rw-r--r--x11-terms/mrxvt/files/mrxvt-0.5.4-libpng14.patch33
2 files changed, 46 insertions, 0 deletions
diff --git a/x11-terms/mrxvt/files/mrxvt-0.5.4-001-fix-segfault-when-wd-empty.patch b/x11-terms/mrxvt/files/mrxvt-0.5.4-001-fix-segfault-when-wd-empty.patch
new file mode 100644
index 000000000000..a52a10269bc1
--- /dev/null
+++ b/x11-terms/mrxvt/files/mrxvt-0.5.4-001-fix-segfault-when-wd-empty.patch
@@ -0,0 +1,13 @@
+Index: src/tabbar.c
+===================================================================
+--- src/tabbar.c (revision 337)
++++ src/tabbar.c (working copy)
+@@ -1327,7 +1327,7 @@
+ if( p.we_wordc > 1)
+ rxvt_msg( DBG_ERROR, DBG_TABBAR,
+ "Too many words when expanding %s\n", cwdOption );
+- else
++ else if( NOT_NULL( *p.we_wordv ) )
+ {
+ filename = *p.we_wordv;
+
diff --git a/x11-terms/mrxvt/files/mrxvt-0.5.4-libpng14.patch b/x11-terms/mrxvt/files/mrxvt-0.5.4-libpng14.patch
new file mode 100644
index 000000000000..a475b70685dc
--- /dev/null
+++ b/x11-terms/mrxvt/files/mrxvt-0.5.4-libpng14.patch
@@ -0,0 +1,33 @@
+http://repos.archlinux.org/wsvn/packages/mrxvt/trunk/libpng14.patch
+
+--- configure.ac
++++ configure.ac
+@@ -952,7 +952,7 @@
+ if test "x$support_png" = "xyes"; then
+ AC_CHECK_LIB(
+ png,
+- png_check_sig,
++ png_sig_cmp,
+ [],
+ [support_png=no],
+ [-lz -lm]
+--- src/mpng.c
++++ src/mpng.c
+@@ -83,7 +83,7 @@
+ display_depth = XDefaultDepth(display,XDefaultScreen(display));
+
+ fread(sig, 1, 8, ifile);
+- if (!png_check_sig(sig, 8)){
++ if (png_sig_cmp(sig, 0, 8)){
+ fclose(ifile);
+ return -1;
+ }
+@@ -113,7 +113,7 @@
+
+ if (png_depth < 8){
+ if (png_color_type == PNG_COLOR_TYPE_GRAY ){
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ png_row_bytes = png_width;
+ }else{
+ png_set_expand(png_ptr);