summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-11 20:21:56 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-11 20:46:39 +0100
commitfed8c6e66200ecf9b5f3242024777294aca4bf26 (patch)
tree4386db67c314cd11db7f532b8363be8fb3470d79 /x11-terms/roxterm/roxterm-3.1.5-r1.ebuild
parentx11-plugins/wmudmount: Depend on virtual/imagemagick-tools (diff)
downloadgentoo-fed8c6e66200ecf9b5f3242024777294aca4bf26.tar.gz
gentoo-fed8c6e66200ecf9b5f3242024777294aca4bf26.tar.bz2
gentoo-fed8c6e66200ecf9b5f3242024777294aca4bf26.zip
x11-terms/roxterm: Depend on virtual/imagemagick-tools
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3907
Diffstat (limited to 'x11-terms/roxterm/roxterm-3.1.5-r1.ebuild')
-rw-r--r--x11-terms/roxterm/roxterm-3.1.5-r1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/x11-terms/roxterm/roxterm-3.1.5-r1.ebuild b/x11-terms/roxterm/roxterm-3.1.5-r1.ebuild
new file mode 100644
index 000000000000..45c68df4c5fa
--- /dev/null
+++ b/x11-terms/roxterm/roxterm-3.1.5-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_4 )
+inherit gnome2-utils python-any-r1 toolchain-funcs
+
+DESCRIPTION="A terminal emulator designed to integrate with the ROX environment"
+HOMEPAGE="http://roxterm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/roxterm/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="1"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/dbus-glib-0.100
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/vte:2.91
+ !x11-terms/roxterm:0"
+# slotted versions of roxterm need block one another due to file collisions. #565288
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libxslt
+ dev-python/lockfile
+ virtual/pkgconfig
+ virtual/imagemagick-tools
+ nls? ( app-text/po4a sys-devel/gettext )"
+
+src_configure() {
+ local myconf=(
+ CC="$(tc-getCC)"
+ CFLAGS="${CFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ --prefix=/usr
+ --docdir="/usr/share/doc/${PF}"
+ --destdir="${D}"
+ )
+
+ use nls || myconf+=( --disable-gettext --disable-po4a --disable-translations )
+ ./mscript.py configure "${myconf[@]}"
+}
+
+src_compile() {
+ ./mscript.py build
+}
+
+src_install() {
+ ./mscript.py install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}