summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-08-04 19:40:39 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-08-04 19:50:39 +0300
commit0f78b717349e850c91f533ba94649507c77ffe15 (patch)
tree5fd5aa054a996f395c7e9c68022bb44f8a6dddba /x11-terms/terminology
parentx11-wm/enlightenment: bump to 0.24.2 (diff)
downloadgentoo-0f78b717349e850c91f533ba94649507c77ffe15.tar.gz
gentoo-0f78b717349e850c91f533ba94649507c77ffe15.tar.bz2
gentoo-0f78b717349e850c91f533ba94649507c77ffe15.zip
x11-terms/terminology: bump to 1.8.0
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms/terminology')
-rw-r--r--x11-terms/terminology/Manifest1
-rw-r--r--x11-terms/terminology/terminology-1.8.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/x11-terms/terminology/Manifest b/x11-terms/terminology/Manifest
index 3225572300a5..952fad350ddf 100644
--- a/x11-terms/terminology/Manifest
+++ b/x11-terms/terminology/Manifest
@@ -1 +1,2 @@
DIST terminology-1.7.0.tar.xz 4922616 BLAKE2B 40ca7bfff534e773b4c188970ecd82e44c2eee7a75eb2a6d4fc6a8635c57857e2037a319818a437843271faa42995f25b613091a4463c02427d835c6ae572722 SHA512 9635da6a51344fbbafd333592252c2539daa795600b4a1d5ea5710e294f18ff9f5667706c789a3c91378b493ae631df47faec2bc43b4cc48d0266506ab3f2e78
+DIST terminology-1.8.0.tar.xz 4938932 BLAKE2B 06d3cb7e4b1f7c069f44e1f7a78d29fe07bb4910e8f9b210363b96f18338f2eb97f247279e4e1e4d2f27ff48db35844f94dabee23a5ca50a6faecada0151bae8 SHA512 2d99b010e6a68f5cbe2d783138cd7321d878206f8000f3f6c59446bc4c998cb4944925ff61356f979c35c115fc87e311d7abbb12919ed52ef36ea9ff25c44d8f
diff --git a/x11-terms/terminology/terminology-1.8.0.ebuild b/x11-terms/terminology/terminology-1.8.0.ebuild
new file mode 100644
index 000000000000..df1a367bd14e
--- /dev/null
+++ b/x11-terms/terminology/terminology-1.8.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson xdg-utils
+
+DESCRIPTION="Feature rich terminal emulator using the Enlightenment Foundation Libraries"
+HOMEPAGE="https://www.enlightenment.org/about-terminology"
+SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="extras nls"
+
+RDEPEND="|| ( dev-libs/efl[gles2-only] dev-libs/efl[opengl] )
+ || ( dev-libs/efl[X] dev-libs/efl[wayland] )
+ app-arch/lz4
+ dev-libs/efl[eet,fontconfig]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use nls)
+ $(meson_use extras tests)
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}