summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-01-04 18:09:19 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-01-04 18:19:16 +0200
commit2a74d585403c1722aed194351ab8700300f02e69 (patch)
tree016036e4e98f89f29aa529bcfad862d27dad432f /x11-terms/terminology
parentx11-wm/enlightenment: add 0.25.1 (diff)
downloadgentoo-2a74d585403c1722aed194351ab8700300f02e69.tar.gz
gentoo-2a74d585403c1722aed194351ab8700300f02e69.tar.bz2
gentoo-2a74d585403c1722aed194351ab8700300f02e69.zip
x11-terms/terminology: add 1.12.1
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms/terminology')
-rw-r--r--x11-terms/terminology/Manifest1
-rw-r--r--x11-terms/terminology/terminology-1.12.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/x11-terms/terminology/Manifest b/x11-terms/terminology/Manifest
index 58e9a7146a0e..bb0226c076fc 100644
--- a/x11-terms/terminology/Manifest
+++ b/x11-terms/terminology/Manifest
@@ -1 +1,2 @@
DIST terminology-1.11.0.tar.xz 4984128 BLAKE2B 059de50cd9e4c94f628e992f44909a1f2dcd79ce01c48cbde2f043f08a2e22c6ded1e7de61f84bd8b37961191501a4ec32ca027c32994a1d7b1929a2270c977e SHA512 9c26c383760a497cc9bbb36aa8bd154599a708cb6bbede26fc2f5c6d6459a51d566066c4d9b64198afaadd94463ce83bca4b392551fd4ff3e68d8a4383d6c403
+DIST terminology-1.12.1.tar.xz 2722144 BLAKE2B ce6eea2fd6efe8a4a6d654f8e7899336b3bb7a1d2f1728c2ac2f1b367972c8b222e665309e2b704dd1f3bb774784d218789bcd8134348893a265c0e50fa855d9 SHA512 036f1e516d5f9c44185fc417266022bb4a3c34839451b2bd7ab64c9610e71cd1690faee014cf8364ceac12261cb9b57501446a3e6e58ac13f98f11064498a43b
diff --git a/x11-terms/terminology/terminology-1.12.1.ebuild b/x11-terms/terminology/terminology-1.12.1.ebuild
new file mode 100644
index 000000000000..68b2732bf05b
--- /dev/null
+++ b/x11-terms/terminology/terminology-1.12.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson python-any-r1 xdg
+
+DESCRIPTION="Feature rich terminal emulator using the Enlightenment Foundation Libraries"
+HOMEPAGE="https://www.enlightenment.org/about-terminology"
+SRC_URI="https://download.enlightenment.org/rel/apps/terminology/${P}.tar.xz https://downloads.terminolo.gy/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="extras nls"
+
+RDEPEND="|| ( dev-libs/efl[X,opengl] dev-libs/efl[wayland] )
+ app-arch/lz4
+ >=dev-libs/efl-1.26.1[eet,fontconfig]"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ virtual/libintl
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Fix python shebangs for python-exec[-native-symlinks], #766081
+ local shebangs=($(grep -rl "#!/usr/bin/env python3" || die))
+ python_fix_shebang -q ${shebangs[*]}
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use nls)
+ $(meson_use extras tests)
+ )
+
+ meson_src_configure
+}