summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-04-15 04:56:38 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-04-15 05:11:52 -0400
commit004aca0acccd8e2e5a25094b89bd3940cd7e1f25 (patch)
tree0d7754b996fa2ca1ed14a0baa9a615093d4456ef /x11-terms
parentx11-terms/kitty-terminfo: add 0.28.0 (diff)
downloadgentoo-004aca0acccd8e2e5a25094b89bd3940cd7e1f25.tar.gz
gentoo-004aca0acccd8e2e5a25094b89bd3940cd7e1f25.tar.bz2
gentoo-004aca0acccd8e2e5a25094b89bd3940cd7e1f25.zip
x11-terms/kitty-shell-integration: add 0.28.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest1
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.28.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index f2aeda1975f7..071daae2f8f4 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1,2 +1,3 @@
DIST kitty-0.26.5.tar.xz 4749988 BLAKE2B 488969b4d7c6aed489a540a8e3bee183345fcfb7e05ae5604f4af40f0720ed931cff82cf389e2fa4015eed74762c0630481a99eeb9302c22c89c4f3e247170d4 SHA512 086ae03d0e382afbe3001e357ef51388c7a8e81fa5b4bf9ce8b123a7fc8bfff3bd68d074e926f540a1f2b83062baa831e44d29c017cabfe8221bebe49b64e808
DIST kitty-0.27.1.tar.xz 5045588 BLAKE2B 2381b3e9af26bb8a4c4358318289e9ef49ba1e38678ef192fd815ced962644671433a80f124579fb593257351cd8e0a61f845975d61d0d33f42b9d470ef130f0 SHA512 484d451b418defc7256319730d623224e3744d6200989d92839c40c951fdb213fe2ef472ddf968f695e499aa6c35d994ad76bb0eb28bca80ec8644b2ead40d56
+DIST kitty-0.28.0.tar.xz 7900352 BLAKE2B fea1944e818354522a386d9d6bfa778e70bef3404c3b3f3c87667cee16edc54206540d0ef022f1383e22ed1caf929cc839b226da21c86f9d9b1cda8f8a9a847f SHA512 d133dab019c67367e90cc2e2dce7e614a65400b079cdcfa854f2e1cb7399af7b1ba0f3ef4d30867ae588c9919a772c03ee12457b6dc5922f58c034a6da927127
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.28.0.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.28.0.ebuild
new file mode 100644
index 000000000000..683e7101b6b5
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.28.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+
+ # this is used internally by the ssh kitten and is not useful there
+ rm -r "${ED}"/usr/share/kitty/shell-integration/ssh || die
+}