summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gmail.com>2018-05-12 05:54:18 +0300
committerMichał Górny <mgorny@gentoo.org>2018-05-13 09:27:05 +0200
commit18cfe9ffa6718347b5e4823c955be0789232e57f (patch)
tree7dcb61495efeb3e4ed2ebc873558e5e172d2f00e /x11-terms
parentx11-terms/terminology: bump to 1.2.0 (diff)
downloadgentoo-18cfe9ffa6718347b5e4823c955be0789232e57f.tar.gz
gentoo-18cfe9ffa6718347b5e4823c955be0789232e57f.tar.bz2
gentoo-18cfe9ffa6718347b5e4823c955be0789232e57f.zip
x11-terms/terminology: update -9999 to reflect latest release
Updated homepage and added nls USE flag. Closes: https://bugs.gentoo.org/642066 Closes: https://github.com/gentoo/gentoo/pull/8356 Package-Manager: Portage[mgorny]-2.3.33.1
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/terminology/terminology-9999.ebuild36
1 files changed, 19 insertions, 17 deletions
diff --git a/x11-terms/terminology/terminology-9999.ebuild b/x11-terms/terminology/terminology-9999.ebuild
index 141d654af246..b8b33368f9b5 100644
--- a/x11-terms/terminology/terminology-9999.ebuild
+++ b/x11-terms/terminology/terminology-9999.ebuild
@@ -1,27 +1,29 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-MY_P=${P/_/-}
-
-if [[ "${PV}" != "9999" ]] ; then
- SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${MY_P}.tar.xz"
- KEYWORDS="~amd64 ~x86"
-else
- inherit git-r3
- EGIT_REPO_URI="https://git.enlightenment.org/apps/${PN}.git"
-fi
-
-inherit meson
+inherit git-r3 meson
DESCRIPTION="Feature rich terminal emulator using the Enlightenment Foundation Libraries"
-HOMEPAGE="https://www.enlightenment.org/p.php?p=about/terminology"
+HOMEPAGE="https://www.enlightenment.org/about-terminology"
+EGIT_REPO_URI="https://git.enlightenment.org/apps/${PN}.git"
LICENSE="BSD-2"
SLOT="0"
-IUSE=""
+IUSE="nls"
+
+RDEPEND=">=dev-libs/efl-1.20.0[eet,fontconfig,opengl,X]"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ local emesonargs=(
+ -D nls=$(usex nls true false)
+ )
-RDEPEND=">=dev-libs/efl-1.18[X]"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ meson_src_configure
+}