summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-05-18 11:18:12 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-05-18 11:30:33 -0400
commit1dc6adf4edfdc0c5f2065814b961c154ee527156 (patch)
tree4fb336fc924c4e28ff9fd489a77af9d029f7ba5c /x11-terms
parentsys-boot/refind: drop 0.11.4, 0.12.0-r1 (diff)
downloadgentoo-1dc6adf4edfdc0c5f2065814b961c154ee527156.tar.gz
gentoo-1dc6adf4edfdc0c5f2065814b961c154ee527156.tar.bz2
gentoo-1dc6adf4edfdc0c5f2065814b961c154ee527156.zip
x11-terms/kitty: respect makeopts
Was brought to my attention it wasn't respected, thanks. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty/kitty-0.25.0.ebuild6
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/x11-terms/kitty/kitty-0.25.0.ebuild b/x11-terms/kitty/kitty-0.25.0.ebuild
index 840b21522be6..16daf016bebc 100644
--- a/x11-terms/kitty/kitty-0.25.0.ebuild
+++ b/x11-terms/kitty/kitty-0.25.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit optfeature python-single-r1 toolchain-funcs xdg
+inherit optfeature multiprocessing python-single-r1 toolchain-funcs xdg
if [[ ${PV} == 9999 ]] ; then
inherit git-r3
@@ -71,7 +71,9 @@ PATCHES=(
src_prepare() {
default
- sed -i "s/'x11 wayland'/'$(usev X x11) $(usev wayland)'/" setup.py || die
+ sed -e "s/'x11 wayland'/'$(usev X x11) $(usev wayland)'/" \
+ -e "/num_workers = /s/=.*/= $(makeopts_jobs)/" \
+ -i setup.py || die
if use !transfer; then
sed -i 's/rs_cflag =/& []#/;/files.*rsync/d' setup.py || die
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index 16dd62bce059..259c9f471b3e 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit optfeature python-single-r1 toolchain-funcs xdg
+inherit optfeature multiprocessing python-single-r1 toolchain-funcs xdg
if [[ ${PV} == 9999 ]] ; then
inherit git-r3
@@ -71,7 +71,9 @@ PATCHES=(
src_prepare() {
default
- sed -i "s/'x11 wayland'/'$(usev X x11) $(usev wayland)'/" setup.py || die
+ sed -e "s/'x11 wayland'/'$(usev X x11) $(usev wayland)'/" \
+ -e "/num_workers = /s/=.*/= $(makeopts_jobs)/" \
+ -i setup.py || die
if use !transfer; then
sed -i 's/rs_cflag =/& []#/;/files.*rsync/d' setup.py || die