summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPablo <pord@tuta.io>2020-10-14 21:09:03 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-17 17:04:37 +0300
commit300c582e39d7ce33461b29da6c825fa8899d17b1 (patch)
treeac88ebad29afef64367c411e39c9788df0ad0356 /x11-terms
parentx11-terms/kitty: bump to 0.19.1 and fix tests (diff)
downloadgentoo-300c582e39d7ce33461b29da6c825fa8899d17b1.tar.gz
gentoo-300c582e39d7ce33461b29da6c825fa8899d17b1.tar.bz2
gentoo-300c582e39d7ce33461b29da6c825fa8899d17b1.zip
x11-terms/kitty-terminfo: bump to 0.19.1
Signed-off-by: Pablo Orduna <pabloorduna98@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17930 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-terminfo/Manifest1
-rw-r--r--x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.19.1.patch (renamed from x11-terms/kitty-terminfo/files/kitty-terminfo-setup-9999.patch)0
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.19.1.ebuild41
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild2
4 files changed, 43 insertions, 1 deletions
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
index 4fc88074c08d..f05191489348 100644
--- a/x11-terms/kitty-terminfo/Manifest
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -4,3 +4,4 @@ DIST kitty-0.17.4.tar.xz 3068456 BLAKE2B 7c3be1bd9e1be814ca2c98ac8bed5c8ac906021
DIST kitty-0.18.1.tar.xz 3098940 BLAKE2B c54f9e7996e8e17182d5cdb3f915964b2626985992dc9f8bf2f11d086475fd7b13ee131aaf942f521cd6356ac13f7efdf436253237022532ffc68cb7923bc645 SHA512 d1870fa8c1c42c9a20251ba7819fb649760a98070653cff6bbc0ef86160d6b20070bbfe4e549b80d75d7a78b37cb3c1153e4be246709cf630129cd4d09a76604
DIST kitty-0.18.2.tar.xz 3100228 BLAKE2B ac7c1c6dc9ced4f8ca59c9a9a9ff2d0c6410bbed64efc8528a899b5b55ad008e65bed6ef1b1fdb74da6b4df2ccef63e1d64ffc375ad225243999bcbb2c1378ec SHA512 12b17f241884347e841b597cc86ac7dec9f509350af33de4e790f586b1cb8a5b89222f25f710f1f5ab82ea09cb1c7b0fa9ffee869cbae497e2a2ab0c6ef1b5a0
DIST kitty-0.18.3.tar.xz 3107268 BLAKE2B 5a81552d59f5232253c0c23a9a4eb88950a5d6e9c3ca69412ca7d56d521cb69f424461df2718774489de42c78de8253d2336e4bf7f352b488364fe30f418b0c4 SHA512 77636c4d1c21157e86cae3a88bca8b161207c1f1112ce60d11d04e79cf6e8ed331085f99e0caa20b7b4f297d8bf193aeb7afa8679c871085cc9d328ed8da3ad7
+DIST kitty-0.19.1.tar.xz 3262516 BLAKE2B 82520e79125483a9e3b6592bdf38e782231934214a989fe44ad6c587a025338a98f1d09219a315dfbffc8264be5f5b2352db457b5e11edc2d08af594989a8092 SHA512 3a61d15598f32634646cbf0be596e9023420452130be1b9a718d2ce7daf3edeee6d2ba3abfe91c768758b043ed46423a2382680f9dd65fd6a6c57dbcd0fc1fd3
diff --git a/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-9999.patch b/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.19.1.patch
index 865ac2b0331d..865ac2b0331d 100644
--- a/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-9999.patch
+++ b/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.19.1.patch
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.19.1.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.19.1.ebuild
new file mode 100644
index 000000000000..cc2defc98684
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.19.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-any-r1 toolchain-funcs xdg
+
+DESCRIPTION="Terminfo for kitty, an OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}"/kitty-terminfo-setup-0.19.1.patch
+)
+
+# kitty-terminfo is a split package from kitty that only installs the terminfo
+# file. As tests are designed to be run with the whole package compiled they
+# would fail in this case.
+RESTRICT="test"
+
+src_compile() {
+ "${EPYTHON}" setup.py \
+ --verbose $(usex debug --debug "") \
+ --libdir-name $(get_libdir) \
+ linux-terminfo || die "Failed to compile kitty."
+}
+
+src_install() {
+ insinto /usr
+ doins -r linux-package/*
+}
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild
index 6e6b7a4abe73..09d8d433727b 100644
--- a/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild
@@ -18,7 +18,7 @@ IUSE="debug"
DEPEND="${PYTHON_DEPS}"
PATCHES=(
- "${FILESDIR}"/kitty-terminfo-setup-9999.patch
+ "${FILESDIR}"/kitty-terminfo-setup-0.19.1.patch
)
# kitty-terminfo is a split package from kitty that only installs the terminfo