summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Gstädtner <thomas@gstaedtner.net>2017-11-15 04:08:06 +0100
committerThomas Sachau <tommy@gentoo.org>2017-12-17 13:33:44 +0100
commit332c690cf3239240234f57e07f3fb94f6f6425f6 (patch)
treea7515148190ac8a845af7101bd780a8796da20b4 /x11-terms
parentapp-emulation/spim: remove old (diff)
downloadgentoo-332c690cf3239240234f57e07f3fb94f6f6425f6.tar.gz
gentoo-332c690cf3239240234f57e07f3fb94f6f6425f6.tar.bz2
gentoo-332c690cf3239240234f57e07f3fb94f6f6425f6.zip
x11-terms/terminology: fix up live ebuild
Upstream migrated to meson as build system, autotools support has been removed. The meson eclass requires EAPI 6, which the enlightenment eclass does not support. I feel the enlightenment.eclass has outlived its usefulness, so this patch drops it completely and replaces it by including an additional 3 lines of boilerplate, which is all that using the eclass saved. Package-Manager: Portage-2.3.13, Repoman-2.3.4 Closes: https://github.com/gentoo/gentoo/pull/6193 Closes: https://bugs.gentoo.org/637544
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/terminology/terminology-9999.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/x11-terms/terminology/terminology-9999.ebuild b/x11-terms/terminology/terminology-9999.ebuild
index f28072ea6386..ab915d1adff7 100644
--- a/x11-terms/terminology/terminology-9999.ebuild
+++ b/x11-terms/terminology/terminology-9999.ebuild
@@ -1,23 +1,26 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
MY_P=${P/_/-}
-if [[ "${PV}" == "9999" ]] ; then
- EGIT_SUB_PROJECT="apps"
- EGIT_URI_APPEND="${PN}"
-else
+if [[ "${PV}" != "9999" ]] ; then
SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${MY_P}.tar.xz"
KEYWORDS="~amd64 ~x86"
+else
+ EGIT_REPO_URI="https://git.enlightenment.org/apps/${PN}.git"
fi
-inherit enlightenment
+inherit git-r3 meson
DESCRIPTION="Feature rich terminal emulator using the Enlightenment Foundation Libraries"
HOMEPAGE="https://www.enlightenment.org/p.php?p=about/terminology"
-RDEPEND=">=dev-libs/efl-1.18"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=dev-libs/efl-1.18[X]"
DEPEND="${RDEPEND}
virtual/pkgconfig"