summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-05-21 10:10:20 +0100
committerMatthew Smith <matthew@gentoo.org>2022-05-21 10:10:20 +0100
commit556a1f65d35ad0877383b4958f0099715d22b3de (patch)
treeaf86f29842019633b591fa7cf033814da3b9697f /x11-terms
parentdev-python/flask-mail: Enable py3.11 (diff)
downloadgentoo-556a1f65d35ad0877383b4958f0099715d22b3de.tar.gz
gentoo-556a1f65d35ad0877383b4958f0099715d22b3de.tar.bz2
gentoo-556a1f65d35ad0877383b4958f0099715d22b3de.zip
x11-terms/zutty: add 0.12
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/zutty/Manifest1
-rw-r--r--x11-terms/zutty/files/zutty-0.12-cxxflags.patch27
-rw-r--r--x11-terms/zutty/zutty-0.12.ebuild41
3 files changed, 69 insertions, 0 deletions
diff --git a/x11-terms/zutty/Manifest b/x11-terms/zutty/Manifest
index dda55cd631d9..b6740d9b6972 100644
--- a/x11-terms/zutty/Manifest
+++ b/x11-terms/zutty/Manifest
@@ -1 +1,2 @@
DIST zutty-0.11.tar.gz 343469 BLAKE2B 9cd040e72d0ea76a526d099265b3a0974d40b1b8b679ff3baafc47f827b140943ac8bc13676831245e219ca1335ded7aca1e7826baf175fc63e88012791785e1 SHA512 84e8402a310adc80c698ded38fa3eb8ba44034f391e2538bccbdbc4082e239dc0d6ceb20504eeab4e5d2499ded55ef0941ae2e5d07eeb809d1059e5449cdb708
+DIST zutty-0.12.tar.gz 348226 BLAKE2B 8d065928fe3e8049e63f1e679d4e8d2ef6643b01b098698594d536c6fa9494a2a934dce3e4fe60594be4f1b56691a83a8e7fab0dd1ec6c09e12eeb1e69354f5e SHA512 d10289a51469ec6352a5b1feefb732dce7cf507b02ce57e64f8f65443f4533b8d61f357dec92cb00b58386416470928d763290a6d4ff714f65f98f1f09d60083
diff --git a/x11-terms/zutty/files/zutty-0.12-cxxflags.patch b/x11-terms/zutty/files/zutty-0.12-cxxflags.patch
new file mode 100644
index 000000000000..11b3066e50ba
--- /dev/null
+++ b/x11-terms/zutty/files/zutty-0.12-cxxflags.patch
@@ -0,0 +1,27 @@
+From 06927a1f2f88bd9d5f4bb8056661ffbc4a0aeb77 Mon Sep 17 00:00:00 2001
+From: Matthew Smith <matt@offtopica.uk>
+Date: Wed, 19 Jan 2022 18:07:55 +0000
+Subject: [PATCH] Remove default CXXFLAGS and LINKFLAGS
+
+---
+ wscript | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/wscript b/wscript
+index d2bfbc8..b38b50b 100644
+--- a/wscript
++++ b/wscript
+@@ -69,10 +69,6 @@ def configure(cfg):
+ ['-DDEBUG', '-Og', '-g', '-ggdb'])
+ else:
+ cfg.env.target = 'zutty'
+- cfg.env.append_value('CXXFLAGS',
+- ['-Werror', '-O3', '-flto'])
+- cfg.env.append_value('LINKFLAGS',
+- ['-flto'])
+
+ cfg.check_cfg(package='freetype2', args=['--cflags', '--libs'],
+ uselib_store='FT')
+--
+2.34.1
+
diff --git a/x11-terms/zutty/zutty-0.12.ebuild b/x11-terms/zutty/zutty-0.12.ebuild
new file mode 100644
index 000000000000..10690f8057ce
--- /dev/null
+++ b/x11-terms/zutty/zutty-0.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="X terminal emulator rendering through OpenGL ES Compute Shaders"
+HOMEPAGE="https://tomscii.sig7.se/zutty/ https://github.com/tomszilagyi/zutty"
+SRC_URI="https://github.com/tomszilagyi/zutty/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# It is possible to run the tests using virtualx, but it seems to take
+# screenshots of the terminal window, and compares checksums that never
+# seem to match.
+RESTRICT="test"
+
+RDEPEND="
+ media-libs/freetype:2
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXmu
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Remove default CXX/LDFLAGS, bug #830405.
+ "${FILESDIR}"/${PN}-0.12-cxxflags.patch
+)
+
+DOCS=( doc/KEYS.org doc/USAGE.org )