summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-22 07:37:28 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-11-22 08:00:13 -0500
commit62ba6f2e5398cf7cdc8341690bb75cbbf8cc124f (patch)
tree317dbe015ee482b9d49ff29cce28a5d6b31c5b75 /x11-terms
parentdev-python/pytest-cov: remove unused patch(es) (diff)
downloadgentoo-62ba6f2e5398cf7cdc8341690bb75cbbf8cc124f.tar.gz
gentoo-62ba6f2e5398cf7cdc8341690bb75cbbf8cc124f.tar.bz2
gentoo-62ba6f2e5398cf7cdc8341690bb75cbbf8cc124f.zip
x11-terms/kitty: adjust live further for go-module.eclass
This is not fully a Go package, there's just a helper tool written in Go. But go-module sets some broad assumptions that everything is Go even if we were to use GO_OPTIONAL (it's tempting to simply not use the eclass, only need to set a few variables + BDEPEND if we're not going to use EGO_SUM). Also quote EPYTHON while here, technically should never have spaces per definition but let's not rely on this too much for eclasses. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index 914583b0f335..d9660ea7b4f4 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -66,6 +66,9 @@ BDEPEND="
wayland? ( dev-util/wayland-scanner )"
[[ ${PV} == 9999 ]] || BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )"
+# override go-module.eclass' .* to only consider the Go written binary
+QA_FLAGS_IGNORED="usr/bin/kitty-tool"
+
src_unpack() {
if [[ ${PV} == 9999 ]]; then
git-r3_src_unpack
@@ -108,8 +111,8 @@ src_compile() {
--verbose
)
- edo ${EPYTHON} setup.py linux-package "${conf[@]}"
- use test && edo ${EPYTHON} setup.py build-launcher "${conf[@]}"
+ edo "${EPYTHON}" setup.py linux-package "${conf[@]}"
+ use test && edo "${EPYTHON}" setup.py build-launcher "${conf[@]}"
[[ ${PV} == 9999 ]] || mv linux-package/share/doc/{${PN},${PF}} || die
rm -r linux-package/share/terminfo || die
@@ -125,6 +128,11 @@ src_install() {
fperms +x /usr/bin/kitty \
/usr/$(get_libdir)/kitty/shell-integration/ssh/{askpass.py,kitty}
+
+ # go-module.eclass force-restricts strip, allow except for Go
+ # note: placebo given this is not respected by portage (bug #697960)
+ dostrip /
+ dostrip -x /usr/bin/kitty-tool
}
pkg_postinst() {