summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-05-16 19:58:15 +0200
committerMarek Szuba <marecki@gentoo.org>2021-05-16 20:03:37 +0200
commit67cea2804f7ceffb76b6280e33c1bcececfe0e6a (patch)
treeb6d549092764a2783828ac9990152de68d66c07e /x11-terms
parentdev-java/snakeyaml: removed obsolete and vulnerable 1.16 (diff)
downloadgentoo-67cea2804f7ceffb76b6280e33c1bcececfe0e6a.tar.gz
gentoo-67cea2804f7ceffb76b6280e33c1bcececfe0e6a.tar.bz2
gentoo-67cea2804f7ceffb76b6280e33c1bcececfe0e6a.zip
x11-terms/rxvt-unicode: add 9.26
No 24-bit colour support for now, the 9.22 patch does not apply any more due to changes in how urxvt handles the background. On the plus side, SGR mouse support is now official. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/rxvt-unicode/Manifest1
-rw-r--r--x11-terms/rxvt-unicode/files/urxvtd.socket8
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.26.ebuild89
3 files changed, 98 insertions, 0 deletions
diff --git a/x11-terms/rxvt-unicode/Manifest b/x11-terms/rxvt-unicode/Manifest
index 7a676fb3fd40..369cb6668995 100644
--- a/x11-terms/rxvt-unicode/Manifest
+++ b/x11-terms/rxvt-unicode/Manifest
@@ -1,2 +1,3 @@
DIST rxvt-unicode-9.22.tar.bz2 931198 BLAKE2B ea9a12e4a8396ed6be12b4d50ae260a0376902dbd47b0628bb14ce0509c5d89f5a80370b413fdb9df9b8b81728ec26e115cbf0d88ab6e9cb2a87b03b5d79c432 SHA512 b39f1b2cbe6dd3fbd2a0ad6a9d391a2b6f49d7c5e67bc65fe44a9c86937f8db379572c67564c6e21ff6e09b447cdfd4e540544e486179e94da0e0db679c04dd9
DIST rxvt-unicode-9.22_24-bit-color_cpixl-20201108.patch.xz 8116 BLAKE2B 27940ad42ee3f26c357a50b7fae1e1539acec71f5ff43e7ed16167d0adb175c4de20ba84880f25eec0817703d937d097fda228541d16511811efe5816109e71b SHA512 2b8bbb90c6bb223f622c1e99d62a70a812604d1f8e57cea37a8faf0af578588d3888ea8009568d623710cc03e020a69269770e23476fd9ff9e46dbd9ea23f540
+DIST rxvt-unicode-9.26.tar.bz2 904950 BLAKE2B 1790d02eeadf630cc9bc718288af2f6bd19c3e320d3dbfa44c8cef516c8e790e0abfbfe4e557795749ddd3ec41b8358f6eac623c060240f091b3e84a549151ad SHA512 35560b57730e17c9542ea4a615fd86ce703c4e6421323e8fe1570007737a880fde90d17943e5af9e170be4111b9769f4aa7e57efca5428421fdc1c299112f8e0
diff --git a/x11-terms/rxvt-unicode/files/urxvtd.socket b/x11-terms/rxvt-unicode/files/urxvtd.socket
new file mode 100644
index 000000000000..4da0499c7bba
--- /dev/null
+++ b/x11-terms/rxvt-unicode/files/urxvtd.socket
@@ -0,0 +1,8 @@
+[Unit]
+Description=rxvt-unicode terminal daemon socket
+
+[Socket]
+ListenStream=%h/.urxvt/urxvtd-%H
+
+[Install]
+WantedBy=sockets.target
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.26.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.26.ebuild
new file mode 100644
index 000000000000..9261d793fe79
--- /dev/null
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.26.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop flag-o-matic systemd prefix
+
+DESCRIPTION="rxvt clone with xft and unicode support"
+HOMEPAGE="http://software.schmorp.de/pkg/rxvt-unicode.html"
+SRC_URI="http://dist.schmorp.de/rxvt-unicode/Attic/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris"
+IUSE="256-color blink fading-colors +font-styles gdk-pixbuf iso14755 +mousewheel
+ +perl startup-notification unicode3 +utmp +wtmp xft"
+
+RDEPEND=">=sys-libs/ncurses-5.7-r6:=
+ media-libs/fontconfig
+ x11-libs/libX11
+ x11-libs/libXrender
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf )
+ kernel_Darwin? ( dev-perl/Mac-Pasteboard )
+ perl? ( dev-lang/perl:= )
+ startup-notification? ( x11-libs/startup-notification )
+ xft? ( x11-libs/libXft )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+# WARNING: will bdepend on >=sys-devel/autoconf-2.71 (masked as of 2021-05-16) if eautoreconf has to be called
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-9.06-case-insensitive-fs.patch
+ "${FILESDIR}"/${PN}-9.21-xsubpp.patch
+)
+DOCS=(
+ Changes
+ README.FAQ
+ doc/README.xvt
+ doc/changes.txt
+ doc/etc/${PN}.term{cap,info}
+ doc/rxvt-tabbed
+)
+
+src_prepare() {
+ default
+
+ # kill the rxvt-unicode terminfo file - #192083
+ sed -i -e "/rxvt-unicode.terminfo/d" doc/Makefile.in || die "sed failed"
+
+ # use xsubpp from Prefix - #506500
+ hprefixify -q '"' -w "/xsubpp/" src/Makefile.in
+}
+
+src_configure() {
+ # --enable-everything goes first: the order of the arguments matters
+ econf --enable-everything \
+ $(use_enable 256-color) \
+ $(use_enable blink text-blink) \
+ $(use_enable fading-colors fading) \
+ $(use_enable font-styles) \
+ $(use_enable gdk-pixbuf pixbuf) \
+ $(use_enable iso14755) \
+ $(use_enable mousewheel) \
+ $(use_enable perl) \
+ $(use_enable startup-notification) \
+ $(use_enable unicode3) \
+ $(use_enable utmp) \
+ $(use_enable wtmp) \
+ $(use_enable xft)
+}
+
+src_compile() {
+ default
+
+ sed -i \
+ -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
+ "${S}"/doc/rxvt-tabbed || die
+}
+
+src_install() {
+ default
+
+ systemd_douserunit "${FILESDIR}"/urxvtd.service
+ systemd_douserunit "${FILESDIR}"/urxvtd.socket
+
+ make_desktop_entry urxvt rxvt-unicode utilities-terminal \
+ "System;TerminalEmulator"
+}