summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-02-03 05:52:42 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-02-03 06:16:17 -0500
commit73027225dcc9df319fb6520c155446be85fa077d (patch)
tree75b8cbb29bcd5cd5dac6f0b1c35e4fad361eb103 /x11-terms
parentx11-terms/kitty-terminfo: add 0.24.2 (diff)
downloadgentoo-73027225dcc9df319fb6520c155446be85fa077d.tar.gz
gentoo-73027225dcc9df319fb6520c155446be85fa077d.tar.bz2
gentoo-73027225dcc9df319fb6520c155446be85fa077d.zip
x11-terms/kitty-shell-integration: add 0.24.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest1
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index 0e4fcc8541da..fb6397ec9526 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1 +1,2 @@
DIST kitty-0.24.1.tar.xz 4512652 BLAKE2B ea1bf4911a744fb5aaa5fe3d9fc4821880e78c60a0a89ecba12c73623b9b537c2d9d4e494da125669f2fc36f273f49a00cc5825f56184c1b0c69f4c570b2226d SHA512 e590a3abd4ed38ce956ee1e1b9d3679150c83b80df5ed9daf9773d7a278f63dc8a3a563058906d322f9186bece7d479036a502864fd80f45593c4970c056f389
+DIST kitty-0.24.2.tar.xz 4601672 BLAKE2B 6e253863d81f2ef04f5d185cfe4379fe08818992a12a06da2ce2b0958912c4a0dc164b2ac6e8e74e383716e7040b2390bd1123ab4d8d282ede602dfea5cc756f SHA512 6d49b20dbd96ed0a1ed49a4523b65593c547ea2fec46f4c2557e26cdb5048ebaadb2c2118c7a2dd346f83ecab2d0a341d2322ae37ebe49184e22055581c631e7
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.2.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.2.ebuild
new file mode 100644
index 000000000000..80e3667e6412
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+}