summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-11-05 16:03:47 +0100
committerMarek Szuba <marecki@gentoo.org>2020-11-05 16:05:20 +0100
commit9dcf20f5accef069dc1abd4717090853c1ca8d2a (patch)
treef980827ec3fca7ff16b37d32279652ee900a66ed /x11-terms
parentapp-text/rnc2rng: version bump to 2.6.4, fixes #746650 (diff)
downloadgentoo-9dcf20f5accef069dc1abd4717090853c1ca8d2a.tar.gz
gentoo-9dcf20f5accef069dc1abd4717090853c1ca8d2a.tar.bz2
gentoo-9dcf20f5accef069dc1abd4717090853c1ca8d2a.zip
x11-terms/rxvt-unicode: optionally support 24-bit colour mode
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/rxvt-unicode/Manifest1
-rw-r--r--x11-terms/rxvt-unicode/metadata.xml6
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.22-r4.ebuild95
3 files changed, 102 insertions, 0 deletions
diff --git a/x11-terms/rxvt-unicode/Manifest b/x11-terms/rxvt-unicode/Manifest
index 2ef5babc160d..d6f8508233a1 100644
--- a/x11-terms/rxvt-unicode/Manifest
+++ b/x11-terms/rxvt-unicode/Manifest
@@ -1 +1,2 @@
DIST rxvt-unicode-9.22.tar.bz2 931198 BLAKE2B ea9a12e4a8396ed6be12b4d50ae260a0376902dbd47b0628bb14ce0509c5d89f5a80370b413fdb9df9b8b81728ec26e115cbf0d88ab6e9cb2a87b03b5d79c432 SHA512 b39f1b2cbe6dd3fbd2a0ad6a9d391a2b6f49d7c5e67bc65fe44a9c86937f8db379572c67564c6e21ff6e09b447cdfd4e540544e486179e94da0e0db679c04dd9
+DIST rxvt-unicode-9.22_24-bit-color-f45025a.patch.xz 8152 BLAKE2B 373e40b0bf3fe0d0a1b5aaf7a6737194858728aa90bd6095d5b9ba85f5fe4cc6b0225f63352517b30edfc166e7075a9d46f4380b0f8e7ca221c84d057c626c6f SHA512 15a13d7f2867ff2423fe7d0f263c65f4f031cb01940b3237e7038010bce4f7f51777b6bc56f6ecaf323785b35cd97b2313fb11ee6e47773cf0df5720dcee16fc
diff --git a/x11-terms/rxvt-unicode/metadata.xml b/x11-terms/rxvt-unicode/metadata.xml
index b618af536ae5..e088706493d5 100644
--- a/x11-terms/rxvt-unicode/metadata.xml
+++ b/x11-terms/rxvt-unicode/metadata.xml
@@ -7,6 +7,12 @@
</maintainer>
<!-- co-maintainers welcome! -->
<use>
+<flag name="24-bit-color">Enable 24-bit color support. Note that this feature
+ is unofficial, may cause visual glitches due to the fact there is no
+ termcap/terminfo definition for rxvt-unicode-24bit yet so it is necessary
+ to use the one for 256 colours, visibly increases memory usage, and might
+ slow urxvt down dramatically when more than six fonts are in use in a terminal
+ instance.</flag>
<flag name="256-color">Enable 256 color support</flag>
<flag name="blink">Enable blinking text</flag>
<flag name="fading-colors">Enable colors fading when off focus</flag>
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.22-r4.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.22-r4.ebuild
new file mode 100644
index 000000000000..ecc333567f44
--- /dev/null
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.22-r4.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop
+
+COLOUR_PATCH_NAME="${PN}-9.22_24-bit-color-f45025a.patch"
+
+DESCRIPTION="rxvt clone with xft and unicode support"
+HOMEPAGE="http://software.schmorp.de/pkg/rxvt-unicode.html"
+SRC_URI="http://dist.schmorp.de/rxvt-unicode/Attic/${P}.tar.bz2
+ https://dev.gentoo.org/~marecki/dists/${PN}/${COLOUR_PATCH_NAME}.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="
+ -24-bit-color 256-color blink fading-colors +font-styles gdk-pixbuf iso14755 +mousewheel
+ +perl startup-notification unicode3 +utmp +wtmp xft
+"
+RESTRICT="test"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.7-r6:=
+ media-libs/fontconfig
+ x11-libs/libX11
+ x11-libs/libXrender
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf )
+ kernel_Darwin? ( dev-perl/Mac-Pasteboard )
+ perl? ( dev-lang/perl:= )
+ startup-notification? ( x11-libs/startup-notification )
+ xft? ( x11-libs/libXft )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-9.06-case-insensitive-fs.patch
+ "${FILESDIR}"/${PN}-9.21-xsubpp.patch
+ "${WORKDIR}"/${COLOUR_PATCH_NAME}
+)
+DOCS=(
+ Changes
+ README.FAQ
+ doc/README.xvt
+ doc/changes.txt
+ doc/etc/${PN}.term{cap,info}
+ doc/rxvt-tabbed
+)
+
+src_prepare() {
+ default
+
+ # kill the rxvt-unicode terminfo file - #192083
+ sed -i -e "/rxvt-unicode.terminfo/d" doc/Makefile.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ # --enable-everything goes first: the order of the arguments matters
+ econf --enable-everything \
+ $(use_enable 24-bit-color) \
+ $(use_enable 256-color) \
+ $(use_enable blink text-blink) \
+ $(use_enable fading-colors fading) \
+ $(use_enable font-styles) \
+ $(use_enable gdk-pixbuf pixbuf) \
+ $(use_enable iso14755) \
+ $(use_enable mousewheel) \
+ $(use_enable perl) \
+ $(use_enable startup-notification) \
+ $(use_enable unicode3) \
+ $(use_enable utmp) \
+ $(use_enable wtmp) \
+ $(use_enable xft)
+}
+
+src_compile() {
+ default
+
+ sed -i \
+ -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
+ "${S}"/doc/rxvt-tabbed || die
+}
+
+src_install() {
+ default
+
+ make_desktop_entry urxvt rxvt-unicode utilities-terminal \
+ "System;TerminalEmulator"
+}