summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-12-02 08:48:48 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-12-02 09:01:26 +0200
commitedbd6bc6efb5443040f5d54ea6ba760671544523 (patch)
treed250f33ade144807ef289911ef26b7588245e034 /x11-terms
parentdev-db/barman: add 3.2.0 (diff)
downloadgentoo-edbd6bc6efb5443040f5d54ea6ba760671544523.tar.gz
gentoo-edbd6bc6efb5443040f5d54ea6ba760671544523.tar.bz2
gentoo-edbd6bc6efb5443040f5d54ea6ba760671544523.zip
x11-terms/terminology: add 1.13.0
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/terminology/Manifest1
-rw-r--r--x11-terms/terminology/terminology-1.13.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/x11-terms/terminology/Manifest b/x11-terms/terminology/Manifest
index f504b1558631..152f1f88c602 100644
--- a/x11-terms/terminology/Manifest
+++ b/x11-terms/terminology/Manifest
@@ -1 +1,2 @@
DIST terminology-1.12.1.tar.xz 2722144 BLAKE2B ce6eea2fd6efe8a4a6d654f8e7899336b3bb7a1d2f1728c2ac2f1b367972c8b222e665309e2b704dd1f3bb774784d218789bcd8134348893a265c0e50fa855d9 SHA512 036f1e516d5f9c44185fc417266022bb4a3c34839451b2bd7ab64c9610e71cd1690faee014cf8364ceac12261cb9b57501446a3e6e58ac13f98f11064498a43b
+DIST terminology-1.13.0.tar.xz 2765572 BLAKE2B e918feeb848c9373f38a41a99893210e62fd47206d4c9557a0afcd65a25c978671ddcadbdf955b7514754bc6a47dd3c36ff867b14d3cbda48039b8ac6e8502b8 SHA512 95e8f8bdf51e63b07f7bc5bf1aead98b9bd34c58e13df29d4726f1a81e560d071119035aa94218632e840bc5146c3bc475641934eebd6c7e37e00bed94451beb
diff --git a/x11-terms/terminology/terminology-1.13.0.ebuild b/x11-terms/terminology/terminology-1.13.0.ebuild
new file mode 100644
index 000000000000..109a118568bb
--- /dev/null
+++ b/x11-terms/terminology/terminology-1.13.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit meson python-any-r1 xdg
+
+DESCRIPTION="Feature rich terminal emulator using the Enlightenment Foundation Libraries"
+HOMEPAGE="https://www.enlightenment.org/about-terminology"
+SRC_URI="https://download.enlightenment.org/rel/apps/terminology/${P}.tar.xz https://downloads.terminolo.gy/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="extras nls"
+
+RDEPEND="|| ( dev-libs/efl[X] dev-libs/efl[wayland] )
+ app-arch/lz4
+ >=dev-libs/efl-1.26.1[eet,fontconfig]"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ virtual/libintl
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Fix python shebangs for python-exec[-native-symlinks], #766081
+ local shebangs=($(grep -rl "#!/usr/bin/env python3" || die))
+ python_fix_shebang -q ${shebangs[*]}
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use nls)
+ $(meson_use extras tests)
+ )
+
+ meson_src_configure
+}