summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-11-10 03:49:01 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-11-10 05:52:07 -0500
commitef29aedf32bde32e4cb8cf15eaf65a56f9332ff2 (patch)
tree582f88aa299840d2249e214727ef46bc96e60331 /x11-terms
parentx11-terms/kitty: drop 0.23.1 (diff)
downloadgentoo-ef29aedf32bde32e4cb8cf15eaf65a56f9332ff2.tar.gz
gentoo-ef29aedf32bde32e4cb8cf15eaf65a56f9332ff2.tar.bz2
gentoo-ef29aedf32bde32e4cb8cf15eaf65a56f9332ff2.zip
x11-terms/kitty-terminfo: drop 0.23.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.20.1.patch46
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.23.1.ebuild41
2 files changed, 0 insertions, 87 deletions
diff --git a/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.20.1.patch b/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.20.1.patch
deleted file mode 100644
index 67772bfae03d..000000000000
--- a/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.20.1.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 115739fc..b933165c 100755
---- a/setup.py
-+++ b/setup.py
-@@ -906,6 +906,14 @@ def create_linux_bundle_gunk(ddir: str, libdir_name: str) -> None:
- os.makedirs(os.path.dirname(in_src_launcher), exist_ok=True)
- os.symlink(os.path.relpath(launcher, os.path.dirname(in_src_launcher)), in_src_launcher)
-
-+def terminfo(args):
-+ ddir = args.prefix
-+ libdir = os.path.join(ddir, args.libdir_name.strip('/'), 'kitty')
-+ build_terminfo = runpy.run_path('build-terminfo', run_name='import_build')
-+ for x in (libdir, os.path.join(ddir, 'share')):
-+ odir = os.path.join(x, 'terminfo')
-+ safe_makedirs(odir)
-+ build_terminfo['compile_terminfo'](odir)
-
- def macos_info_plist() -> bytes:
- import plistlib
-@@ -1093,7 +1101,7 @@ def safe_remove(*entries: str) -> None:
-
- safe_remove(
- 'build', 'compile_commands.json', 'link_commands.json',
-- 'linux-package', 'kitty.app', 'asan-launcher',
-+ 'linux-package', 'linux-terminfo', 'kitty.app', 'asan-launcher',
- 'kitty-profile', 'kitty/launcher')
- exclude = ('.git',)
- for root, dirs, files in os.walk('.', topdown=True):
-@@ -1116,7 +1124,7 @@ def option_parser() -> argparse.ArgumentParser: # {{{
- 'action',
- nargs='?',
- default=Options.action,
-- choices='build test linux-package kitty.app linux-freeze macos-freeze build-launcher build-frozen-launcher clean export-ci-bundles'.split(),
-+ choices='build test linux-package linux-terminfo kitty.app linux-freeze macos-freeze build-launcher build-frozen-launcher clean export-ci-bundles'.split(),
- help='Action to perform (default is build)'
- )
- p.add_argument(
-@@ -1246,6 +1254,8 @@ def main() -> None:
- elif args.action == 'linux-package':
- build(args, native_optimizations=False)
- package(args, bundle_type='linux-package')
-+ elif args.action == 'linux-terminfo':
-+ terminfo(args)
- elif args.action == 'linux-freeze':
- build(args, native_optimizations=False)
- package(args, bundle_type='linux-freeze')
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.23.1.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.23.1.ebuild
deleted file mode 100644
index 0887b4ffa410..000000000000
--- a/x11-terms/kitty-terminfo/kitty-terminfo-0.23.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit python-any-r1 xdg
-
-DESCRIPTION="Terminfo for kitty, an OpenGL-based terminal emulator"
-HOMEPAGE="https://github.com/kovidgoyal/kitty"
-SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
-S="${WORKDIR}/kitty-${PV}"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-DEPEND="${PYTHON_DEPS}"
-
-PATCHES=(
- "${FILESDIR}"/kitty-terminfo-setup-0.20.1.patch
-)
-
-# kitty-terminfo is a split package from kitty that only installs the terminfo
-# file. As tests are designed to be run with the whole package compiled they
-# would fail in this case.
-RESTRICT="test"
-
-src_compile() {
- "${EPYTHON}" setup.py \
- --verbose $(usex debug --debug "") \
- --libdir-name $(get_libdir) \
- linux-terminfo || die "Failed to compile kitty."
-}
-
-src_install() {
- insinto /usr
- doins -r linux-package/*
-}