summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-04-23 13:27:46 -0300
committerMatt Turner <mattst88@gentoo.org>2023-04-25 11:20:35 -0400
commitfd189934e16ca308ff824c1847337d7d47bde9ca (patch)
treea7119674a0cc92d7af82bfbb1b2150c87c8dbb7d /x11-terms
parentmedia-gfx/gnome-photos: Depend on net-libs/dleyna for upnp-av (diff)
downloadgentoo-fd189934e16ca308ff824c1847337d7d47bde9ca.tar.gz
gentoo-fd189934e16ca308ff824c1847337d7d47bde9ca.tar.bz2
gentoo-fd189934e16ca308ff824c1847337d7d47bde9ca.zip
x11-terms/gnome-terminal: Version bump to 3.48.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/gnome-terminal/Manifest2
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.48.1.ebuild96
2 files changed, 98 insertions, 0 deletions
diff --git a/x11-terms/gnome-terminal/Manifest b/x11-terms/gnome-terminal/Manifest
index 5bdd0fc2aaa0..8b0f4224b7af 100644
--- a/x11-terms/gnome-terminal/Manifest
+++ b/x11-terms/gnome-terminal/Manifest
@@ -4,3 +4,5 @@ DIST gnome-terminal-3.46.8-cntr-ntfy-autottl-ts.patch.xz 35244 BLAKE2B 4a3166b2a
DIST gnome-terminal-3.46.8.tar.bz2 1691033 BLAKE2B efcf6aa6ab0071fd525e2b5d56bb7a6e53bd8072a5c774c3cab7b52f613e60112a5fccebbf6354953acf3a76182d60f9abc2f7122eef017e4a543a68d21b76f1 SHA512 07b8b9a31d5c1f87ff6d9902b56bfe1eb75b32f25e5b5c97448f990f4c4d6ca73709e5af30e09701d2dc55331a33b6f006fdcc696d5c9ffa83e50919ac74fdfc
DIST gnome-terminal-3.48.0-cntr-ntfy-autottl-ts.patch.xz 37800 BLAKE2B 51c7ab8274b8d4ed2ce9a037b9131d728f76ab11d1dc8aec0c66f98905dfdd27c88a99ae655dab73fbf977a594e12e248170291038f49d225b9e102d3929236d SHA512 187c95f9be287beca43ced2143526920e10c3e67a19463c86d3db298191290b5905922656ad315821ab6cf19b81e2b17252f1b150e4e904db93f13ac7b4aa0d2
DIST gnome-terminal-3.48.0.tar.bz2 1697733 BLAKE2B 2b35fe6e3dc2e25befe7f5f18654f5d69c27aa08ae0bf3562920562e2a9886ea4956e00a3111ef565c2cd0cc8fc7b6fc5fc7c688891e0921d8cd23355ddc6995 SHA512 337df221b9c61159e00958856289866c28d74f598a00557028d4c10cd6b9b46e9d417b052ea9fdcc0701f0d7228d603c7531da704c6ce1420733cc04f58fb0cc
+DIST gnome-terminal-3.48.1-cntr-ntfy-autottl-ts.patch.xz 37796 BLAKE2B 91a4d50a0b4bd412e9528ec165e173c22df11749d6a59a46b0e364b4d7f403f8fdd835c29585ab12a8a9a81da42e816fe3dacb3d9cb0c2739e123404d4b57792 SHA512 69e26b0795de566d425c5b4fd389a865aedf28d64d4ad1cced926eefd3177379bdc365cf9ef76773f21d32df24067e1966302ebcab235c63c191219705eb498e
+DIST gnome-terminal-3.48.1.tar.bz2 1701592 BLAKE2B e7889a0e956a6e4195aebd346b88a4679a386eef53258e25d7536b1bcfecc8df7cb43ca82319a4ea187a46021cda8f16fea82d9bf69051c5baf49f9c7443dd03 SHA512 afd6aa357df2261e136fa4e10e37470d765223a9857768b3eaa3e56c8068840abb8a2d2b051a99e83eada5ab1f2da20b0da48202b95cf32bec389381f7e39dca
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.48.1.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.48.1.ebuild
new file mode 100644
index 000000000000..6f6fa7f943e2
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.48.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+inherit gnome.org gnome2-utils meson python-any-r1 readme.gentoo-r1 xdg
+
+DESCRIPTION="A terminal emulator for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="debug +gnome-shell +nautilus vanilla"
+
+# Upstream is hostile and refuses to upload tarballs.
+SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.bz2"
+SRC_URI+=" !vanilla? ( https://dev.gentoo.org/~mattst88/distfiles/${PN}-3.48.1-cntr-ntfy-autottl-ts.patch.xz )"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# FIXME: automagic dependency on gtk+[X], just transitive but needs proper control, bug 624960
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.22.27:3
+ >=x11-libs/vte-0.71.92:2.91[!vanilla?]
+ >=dev-libs/libpcre2-10
+ >=gnome-base/gsettings-desktop-schemas-0.1.0
+ sys-apps/util-linux
+ gnome-shell? ( gnome-base/gnome-shell )
+ nautilus? ( >=gnome-base/nautilus-43.0 )
+"
+DEPEND="${RDEPEND}"
+# itstool required for help/* with non-en LINGUAS, see bug #549358
+# xmllint required for glib-compile-resources, see bug #549304
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To get previous working directory inherited in new opened tab, or
+ notifications of long-running commands finishing, you will need
+ to add the following line to your ~/.bashrc:\n
+ . /etc/profile.d/vte-2.91.sh"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-3.44.1-fix-missing-wexitcode.patch
+ if ! use vanilla; then
+ # https://bugzilla.gnome.org/show_bug.cgi?id=695371
+ # Fedora patches:
+ # Restore transparency support (with compositing WMs only)
+ # OSC 777 desktop notification support (notifications on tabs for long-running commands completing)
+ # Restore "Set title" support
+ # Automatic title updating based on currently running foreground process
+ # https://src.fedoraproject.org/rpms/gnome-terminal/raw/f31/f/gnome-terminal-cntr-ntfy-autottl-ts.patch
+ # Depends on vte[-vanilla] for OSC 777 and the preexec/precmd/etc patches in VTE
+ eapply "${WORKDIR}"/${PN}-3.48.1-cntr-ntfy-autottl-ts.patch
+ fi
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use debug dbg)
+ -Ddocs=false
+ $(meson_use nautilus nautilus_extension)
+ $(meson_use gnome-shell search_provider)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if ! use vanilla; then
+ # Separate "New Window/Tab" menu entries by default, instead of unified "New Terminal"
+ insinto /usr/share/glib-2.0/schemas
+ newins "${FILESDIR}"/separate-new-tab-window.gschema.override org.gnome.Terminal.gschema.override
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}