summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-09-19 01:12:23 -0400
committerTim Harder <radhermit@gentoo.org>2018-09-19 01:16:52 -0400
commitff085532239574e97e0a9a6f1dfe498783345e57 (patch)
tree250046cfcb755e4740dbc7ce4a02cb41ca1b7b2c /x11-terms
parentapp-benchmarks/geekbench: bump to version 4.3.0 (diff)
downloadgentoo-ff085532239574e97e0a9a6f1dfe498783345e57.tar.gz
gentoo-ff085532239574e97e0a9a6f1dfe498783345e57.tar.bz2
gentoo-ff085532239574e97e0a9a6f1dfe498783345e57.zip
x11-terms/kitty: version bump to 0.12.1
Fixes: https://bugs.gentoo.org/663672
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty/Manifest1
-rw-r--r--x11-terms/kitty/kitty-0.12.1.ebuild96
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild2
3 files changed, 98 insertions, 1 deletions
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index 5212aa1030c6..198991d9b355 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -1,2 +1,3 @@
DIST kitty-0.11.1.tar.gz 3924068 BLAKE2B a71535cfffe863ee06f699eba3a06c1665c851673bee0d1134fe992fe0335cc13d9a89cebf5814082a155166aaa0939b0e6296ad567564c608bf72eedce5cce3 SHA512 79a3ed4ffbc58e34e6c907646dc33168a8dcb58db859549549e2983186521dc69990e2d2e3eb120fcd31af03187d9a8233a60b75c205ac4e59bb7b575836cceb
DIST kitty-0.11.2.tar.gz 3442111 BLAKE2B ebd5f11e57dd77a4336dfee51e2cf8c6c218d88957fe8988edcab9ecef73b7934b28e761733e9d8ca7842efb8a53fb30e785ed16fe73ac8c01b04a138d0e17a3 SHA512 28c4f7e8b87479cae47a00ea39ef31171ebeebf4888da4f9eaec250b4ed36ae6076b40e1a3b7ef88da2c9c860ba4d9af279a8b1d0d6e721f9fa3febee89bc151
+DIST kitty-0.12.1.tar.gz 3477416 BLAKE2B 4c8c99a16ec903498b17921093542d4389784c1d5bc8c8cbc2fb4c56aab7a0996f94c9442ca0ce403c2cb660c8a27e4f20165bb8dca6e9ce9eb6c9a06b03c1b9 SHA512 3efdc2ee9d41cddda7ff033fa69531ce48a163ef4b6efa7c5f10ca20511046c26313115383aec6bcef1b2a0fbbac19b2de9a43835130624aada48e12fe54b7df
diff --git a/x11-terms/kitty/kitty-0.12.1.ebuild b/x11-terms/kitty/kitty-0.12.1.ebuild
new file mode 100644
index 000000000000..a97e7a7a8c5a
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.12.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit python-single-r1 toolchain-funcs gnome2-utils
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/kovidgoyal/kitty/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A modern, hackable, featureful, OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug imagemagick wayland"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPS="
+ ${PYTHON_DEPS}
+ >=media-libs/harfbuzz-1.5.0:=
+ sys-libs/zlib
+ media-libs/libpng:0=
+ media-libs/freetype:2
+ media-libs/fontconfig
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libxkbcommon[X]
+ wayland? (
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.12
+ )
+"
+RDEPEND="
+ ${COMMON_DEPS}
+ imagemagick? ( virtual/imagemagick-tools )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-python/sphinx-1.7[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.11.0-flags.patch
+ "${FILESDIR}"/${PN}-0.11.0-svg-icon.patch
+)
+
+src_prepare() {
+ default
+
+ # disable wayland as required
+ if ! use wayland; then
+ sed -i "/'x11 wayland'/s/ wayland//" setup.py || die
+ fi
+
+ # respect doc dir
+ sed -i "/htmldir =/s/appname/'${PF}'/" setup.py
+
+ tc-export CC
+}
+
+doecho() {
+ echo "$@"
+ "$@" || die
+}
+
+src_compile() {
+ doecho "${EPYTHON}" setup.py --verbose $(usex debug --debug "") --libdir-name $(get_libdir) linux-package
+}
+
+src_test() {
+ export KITTY_CONFIG_DIRECTORY=${T}
+ "${EPYTHON}" test.py || die
+}
+
+src_install() {
+ mkdir -p "${ED}"usr || die
+ cp -r linux-package/* "${ED}usr" || die
+ python_fix_shebang "${ED}"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index 8bef706b26df..a97e7a7a8c5a 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7} )
inherit python-single-r1 toolchain-funcs gnome2-utils