summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-07-24 18:23:42 +0200
committerPacho Ramos <pacho@gentoo.org>2018-07-24 18:23:42 +0200
commit9136df1d85a42c41dd4de0d0632c99dd2eb10761 (patch)
treec1245192347a56c57414ab54c4787a01babd0b7b /x11-themes/QGnomePlatform/QGnomePlatform-0.4.ebuild
parentgnome-extra/gnome-shell-extension-gsconnect: Fix description (diff)
downloadgentoo-9136df1d85a42c41dd4de0d0632c99dd2eb10761.tar.gz
gentoo-9136df1d85a42c41dd4de0d0632c99dd2eb10761.tar.bz2
gentoo-9136df1d85a42c41dd4de0d0632c99dd2eb10761.zip
x11-themes/QGnomePlatform: Version bump
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'x11-themes/QGnomePlatform/QGnomePlatform-0.4.ebuild')
-rw-r--r--x11-themes/QGnomePlatform/QGnomePlatform-0.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-themes/QGnomePlatform/QGnomePlatform-0.4.ebuild b/x11-themes/QGnomePlatform/QGnomePlatform-0.4.ebuild
new file mode 100644
index 000000000000..475205e3eceb
--- /dev/null
+++ b/x11-themes/QGnomePlatform/QGnomePlatform-0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qmake-utils
+
+DESCRIPTION="A Qt Platform Theme aimed to accommodate GNOME settings"
+HOMEPAGE="https://github.com/FedoraQt/QGnomePlatform"
+SRC_URI="https://github.com/FedoraQt/QGnomePlatform/archive/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtwidgets:5=
+ x11-libs/gtk+:3[X]
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ INSTALL_ROOT="${D}" default
+}